Build #3 for hexpat-lens-0.1.8

[all reports]

Package hexpat-lens-0.1.8
Install DependencyFailed hexpat-lens-0.1.8
Docs NotTried
Tests NotTried
Time submitted 2019-01-09 15:52:38.900170608 UTC
Compiler ghc-8.6.3
OS linux
Arch x86_64
Dependencies base-4.12.0.0, bytestring-0.10.8.2, deepseq-1.4.4.0, hexpat-0.20.13, hexpat-tagsoup-0.1, lens-4.17
Flags none

Build log

[view raw]

Warning: The install command is a part of the legacy v1 style of cabal usage.

Please switch to using either the new project style and the new-install
command or the legacy v1-install alias as new-style projects will become the
default in the next version of cabal-install. Please file a bug if you cannot
replicate a working v1- use case with the new-style commands.

For more information, see: https://wiki.haskell.org/Cabal/NewBuild

Resolving dependencies...
Starting     StateVar-1.1.1.1
Starting     cabal-doctest-1.0.6
Starting     List-0.6.2
Starting     base-orphans-0.8
Building     StateVar-1.1.1.1
Building     List-0.6.2
Building     base-orphans-0.8
Building     cabal-doctest-1.0.6
Completed    base-orphans-0.8
Starting     call-stack-0.1.0
Completed    StateVar-1.1.1.1
Starting     hashable-1.2.7.0
Building     call-stack-0.1.0
Building     hashable-1.2.7.0
Completed    cabal-doctest-1.0.6
Starting     parallel-3.2.2.0
Completed    List-0.6.2
Starting     primitive-0.6.4.0
Completed    call-stack-0.1.0
Starting     reflection-2.1.4
Building     parallel-3.2.2.0
Building     primitive-0.6.4.0
Building     reflection-2.1.4
Completed    hashable-1.2.7.0
Starting     semigroups-0.18.5
Completed    parallel-3.2.2.0
Starting     tagged-0.8.6
Building     semigroups-0.18.5
Building     tagged-0.8.6
Completed    semigroups-0.18.5
Starting     tagsoup-0.14.7
Building     tagsoup-0.14.7
Completed    reflection-2.1.4
Starting     th-abstraction-0.2.10.0
Completed    tagged-0.8.6
Starting     transformers-compat-0.6.2
Building     th-abstraction-0.2.10.0
Building     transformers-compat-0.6.2
Completed    transformers-compat-0.6.2
Starting     utf8-string-1.0.1.1
Building     utf8-string-1.0.1.1
Completed    th-abstraction-0.2.10.0
Starting     void-0.7.2
Building     void-0.7.2
Completed    void-0.7.2
Starting     contravariant-1.5
Building     contravariant-1.5
Completed    primitive-0.6.4.0
Starting     unordered-containers-0.2.9.0
Building     unordered-containers-0.2.9.0
Completed    utf8-string-1.0.1.1
Starting     distributive-0.6
Completed    contravariant-1.5
Starting     transformers-base-0.4.5.2
Building     transformers-base-0.4.5.2
Completed    tagsoup-0.14.7
Starting     exceptions-0.10.0
Building     distributive-0.6
Building     exceptions-0.10.0
Completed    transformers-base-0.4.5.2
Starting     vector-0.12.0.2
Building     vector-0.12.0.2
Completed    distributive-0.6
Starting     hexpat-0.20.13
Failed to install hexpat-0.20.13
Build log ( /home/builder/.cabal/logs/ghc-8.6.3/hexpat-0.20.13-APjsUQcw9a06j9Ii4BW0W4.log ):
cabal: Entering directory '/tmp/cabal-tmp-3527/hexpat-0.20.13'
Configuring hexpat-0.20.13...
cabal: Missing dependency on a foreign library:
* Missing (or bad) C library: expat
This problem can usually be solved by installing the system package that
provides this library (you may need the "-dev" version). If the library is
already installed but in a non-standard location then you can use the flags
--extra-include-dirs= and --extra-lib-dirs= to specify where it is.If the
library file does exist, it may contain errors that are caught by the C
compiler at the preprocessing stage. In this case you can re-run configure
with the verbosity flag -v3 to see the error messages.

cabal: Leaving directory '/tmp/cabal-tmp-3527/hexpat-0.20.13'
Starting     comonad-5.0.4
Completed    exceptions-0.10.0
Completed    unordered-containers-0.2.9.0
Building     comonad-5.0.4
Completed    comonad-5.0.4
Completed    vector-0.12.0.2
cabal: Error: some packages failed to install:
hexpat-0.20.13-APjsUQcw9a06j9Ii4BW0W4 failed during the configure step. The
exception was:
ExitFailure 1
hexpat-lens-0.1.8-Gg4u3YWmTGY9uREbhttwZ2 depends on hexpat-lens-0.1.8 which
failed to install.
hexpat-tagsoup-0.1-5wIdkGvwKDX4JagqV2kjxV depends on hexpat-tagsoup-0.1 which
failed to install.