Build #2 for hfmt-0.2.0

[all reports]

Package hfmt-0.2.0
Install PlanningFailed
Docs NotTried
Tests NotTried
Time submitted 2021-06-02 17:26:05.183930921 UTC
Compiler ghc-8.10.2
OS linux
Arch x86_64
Dependencies
Flags none

Code Coverage

No Code Coverage was submitted for this report.

Build log

[view raw]

Resolving dependencies...
cabal: Could not resolve dependencies:
[__0] next goal: hfmt (user goal)
[__0] rejecting: hfmt-0.2.3.1, hfmt-0.2.3.0, hfmt-0.2.2, hfmt-0.2.1
(constraint from user target requires ==0.2.0)
[__0] trying: hfmt-0.2.0
[__1] next goal: stylish-haskell (dependency of hfmt)
[__1] rejecting: stylish-haskell-0.12.2.0 (conflict: hfmt =>
stylish-haskell==0.8.*)
[__1] skipping: stylish-haskell-0.12.1.0, stylish-haskell-0.12.0.0,
stylish-haskell-0.11.0.3, stylish-haskell-0.11.0.0, stylish-haskell-0.10.0.0,
stylish-haskell-0.9.4.4, stylish-haskell-0.9.4.3, stylish-haskell-0.9.4.0,
stylish-haskell-0.9.3.0, stylish-haskell-0.9.2.2, stylish-haskell-0.9.2.1,
stylish-haskell-0.9.2.0, stylish-haskell-0.9.1.1, stylish-haskell-0.9.1.0,
stylish-haskell-0.9.0.2, stylish-haskell-0.9.0.1, stylish-haskell-0.9.0.0 (has
the same characteristics that caused the previous version to fail: excluded by
constraint '==0.8.*' from 'hfmt')
[__1] trying: stylish-haskell-0.8.1.0
[__2] next goal: aeson (dependency of stylish-haskell)
[__2] rejecting: aeson-1.5.6.0 (conflict: stylish-haskell => aeson>=0.6 &&
<1.3)
[__2] skipping: aeson-1.5.5.1, aeson-1.5.5.0, aeson-1.5.4.1, aeson-1.5.4.0,
aeson-1.5.3.0, aeson-1.5.2.0, aeson-1.5.1.0, aeson-1.5.0.0, aeson-1.4.7.1,
aeson-1.4.7.0, aeson-1.4.6.0, aeson-1.4.5.0, aeson-1.4.4.0, aeson-1.4.3.0,
aeson-1.4.2.0, aeson-1.4.1.0, aeson-1.4.0.0, aeson-1.3.1.1, aeson-1.3.1.0,
aeson-1.3.0.0 (has the same characteristics that caused the previous version
to fail: excluded by constraint '>=0.6 && <1.3' from 'stylish-haskell')
[__2] trying: aeson-1.2.4.0
[__3] trying: time-1.9.3/installed-1.9.3 (dependency of aeson)
[__4] next goal: th-abstraction (dependency of aeson)
[__4] rejecting: th-abstraction-0.4.2.0 (conflict: aeson =>
th-abstraction>=0.2.2 && <0.3)
[__4] skipping: th-abstraction-0.4.1.0, th-abstraction-0.4.0.0,
th-abstraction-0.3.2.0, th-abstraction-0.3.1.0, th-abstraction-0.3.0.0 (has
the same characteristics that caused the previous version to fail: excluded by
constraint '>=0.2.2 && <0.3' from 'aeson')
[__4] trying: th-abstraction-0.2.11.0
[__5] next goal: template-haskell (dependency of aeson)
[__5] rejecting: template-haskell-2.16.0.0/installed-2.16.0.0 (conflict:
th-abstraction => template-haskell>=2.5 && <2.15)
[__5] skipping: template-haskell-2.17.0.0, template-haskell-2.16.0.0,
template-haskell-2.15.0.0 (has the same characteristics that caused the
previous version to fail: excluded by constraint '>=2.5 && <2.15' from
'th-abstraction')
[__5] rejecting: template-haskell-2.14.0.0, template-haskell-2.13.0.0,
template-haskell-2.12.0.0, template-haskell-2.11.1.0,
template-haskell-2.11.0.0, template-haskell-2.10.0.0,
template-haskell-2.9.0.0, template-haskell-2.8.0.0, template-haskell-2.7.0.0,
template-haskell-2.6.0.0, template-haskell-2.5.0.0, template-haskell-2.4.0.1,
template-haskell-2.4.0.0, template-haskell-2.3.0.1, template-haskell-2.3.0.0,
template-haskell-2.2.0.0 (constraint from non-upgradeable package requires
installed instance)
[__5] fail (backjumping, conflict set: aeson, template-haskell,
th-abstraction)
After searching the rest of the dependency tree exhaustively, these were the
goals I've had most trouble fulfilling: stylish-haskell, aeson, base, hfmt,
time, deepseq, array, template-haskell, th-abstraction
Try running with --minimize-conflict-set to improve the error message.