Build #2 for ipython-kernel-0.10.2.1

[all reports]

Package ipython-kernel-0.10.2.1
Install PlanningFailed
Docs NotTried
Tests NotTried
Time submitted 2020-08-25 14:21:33.904452078 UTC
Compiler ghc-8.6.3
OS linux
Arch x86_64
Dependencies
Flags none

Build log

[view raw]

Resolving dependencies...
cabal: Could not resolve dependencies:
[__0] trying: ipython-kernel-0.10.2.1 (user goal)
[__1] next goal: zeromq4-haskell (dependency of ipython-kernel)
[__1] rejecting: zeromq4-haskell-0.8.0, zeromq4-haskell-0.7.0,
zeromq4-haskell-0.6.7, zeromq4-haskell-0.6.6, zeromq4-haskell-0.6.5,
zeromq4-haskell-0.6.4, zeromq4-haskell-0.6.3, zeromq4-haskell-0.6.2,
zeromq4-haskell-0.6.1, zeromq4-haskell-0.6, zeromq4-haskell-0.5.1,
zeromq4-haskell-0.5, zeromq4-haskell-0.4.1, zeromq4-haskell-0.4,
zeromq4-haskell-0.3.2, zeromq4-haskell-0.3.1, zeromq4-haskell-0.3 (conflict:
pkg-config package libzmq(==4.0 || >4.0) && <5.0, not found in the pkg-config
database)
[__1] trying: zeromq4-haskell-0.2
[__2] next goal: async (dependency of zeromq4-haskell)
[__2] rejecting: async-2.2.2 (conflict: zeromq4-haskell => async==2.0.*)
[__2] skipping: async-2.2.1, async-2.1.1.1, async-2.1.1, async-2.1.0 (has the
same characteristics that caused the previous version to fail: excluded by
constraint '==2.0.*' from 'zeromq4-haskell')
[__2] trying: async-2.0.2
[__3] next goal: base (dependency of ipython-kernel)
[__3] rejecting: base-4.12.0.0/installed-4.12.0.0 (conflict: async =>
base>=4.3 && <4.9)
[__3] skipping: base-4.14.0.0, base-4.13.0.0, base-4.12.0.0, base-4.11.1.0,
base-4.11.0.0, base-4.10.1.0, base-4.10.0.0, base-4.9.1.0, base-4.9.0.0 (has
the same characteristics that caused the previous version to fail: excluded by
constraint '>=4.3 && <4.9' from 'async')
[__3] rejecting: base-4.8.2.0, base-4.8.1.0, base-4.8.0.0, base-4.7.0.2,
base-4.7.0.1, base-4.7.0.0, base-4.6.0.1, base-4.6.0.0, base-4.5.1.0,
base-4.5.0.0, base-4.4.1.0, base-4.4.0.0, base-4.3.1.0, base-4.3.0.0,
base-4.2.0.2, base-4.2.0.1, base-4.2.0.0, base-4.1.0.0, base-4.0.0.0,
base-3.0.3.2, base-3.0.3.1 (constraint from non-upgradeable package requires
installed instance)
[__3] fail (backjumping, conflict set: async, base, ipython-kernel)
After searching the rest of the dependency tree exhaustively, these were the
goals I've had most trouble fulfilling: base, zeromq4-haskell, async,
ipython-kernel
Try running with --minimize-conflict-set to improve the error message.