Build #3 for jni-0.4.0

[all reports]

Package jni-0.4.0
Install ConfigureFailed
Docs NotTried
Tests NotTried
Time submitted 2017-08-31 16:17:53.877484992 UTC
Compiler ghc-8.0.2
OS linux
Arch x86_64
Dependencies base-4.9.1.0, bytestring-0.10.8.1, choice-0.2.2, constraints-0.9.1, containers-0.5.7.1, deepseq-1.4.2.0, inline-c-0.5.6.1, singletons-2.2, thread-local-storage-0.1.2
Flags none

Code Coverage

No Code Coverage was submitted for this report.

Build log

[view raw]

Resolving dependencies...
Configuring ansi-terminal-0.6.3.1...
Configuring base-orphans-0.6...
Building base-orphans-0.6...
Building ansi-terminal-0.6.3.1...
Installed base-orphans-0.6
Configuring byteable-0.1.1...
Building byteable-0.1.1...
Configuring cabal-doctest-1.0.2...
Installed ansi-terminal-0.6.3.1
Building cabal-doctest-1.0.2...
Configuring choice-0.2.2...
Installed byteable-0.1.1
Building choice-0.2.2...
Configuring foundation-0.0.13...
Installed cabal-doctest-1.0.2
Configuring integer-logarithms-1.0.2...
Installed choice-0.2.2
Building foundation-0.0.13...
Building integer-logarithms-1.0.2...
Configuring random-1.1...
Installed integer-logarithms-1.0.2
Building random-1.1...
Configuring safe-0.3.15...
Installed random-1.1
Building safe-0.3.15...
Configuring primitive-0.6.2.0...
Installed safe-0.3.15
Building primitive-0.6.2.0...
Configuring mtl-2.2.1...
Installed primitive-0.6.2.0
Building mtl-2.2.1...
Configuring semigroups-0.18.3...
Installed mtl-2.2.1
Building semigroups-0.18.3...
Configuring syb-0.7...
Installed semigroups-0.18.3
Building syb-0.7...
Configuring th-lift-0.7.7...
Installed syb-0.7
Building th-lift-0.7.7...
Configuring thread-local-storage-0.1.2...
Installed th-lift-0.7.7
Building thread-local-storage-0.1.2...
Configuring text-1.2.2.2...
Installed thread-local-storage-0.1.2
Building text-1.2.2.2...
Configuring transformers-compat-0.5.1.4...
Installed text-1.2.2.2
Building transformers-compat-0.5.1.4...
Installed transformers-compat-0.5.1.4
Configuring ansi-wl-pprint-0.6.8.1...
Building ansi-wl-pprint-0.6.8.1...
Configuring tf-random-0.5...
Installed foundation-0.0.13
Configuring th-expand-syns-0.4.3.0...
Installed ansi-wl-pprint-0.6.8.1
Building tf-random-0.5...
Building th-expand-syns-0.4.3.0...
Configuring hashable-1.2.6.1...
Installed th-expand-syns-0.4.3.0
Building hashable-1.2.6.1...
Configuring vector-0.12.0.1...
Installed tf-random-0.5
Building vector-0.12.0.1...
Configuring parsec-3.1.11...
Installed hashable-1.2.6.1
Building parsec-3.1.11...
Installed parsec-3.1.11
Configuring memory-0.14.6...
Building memory-0.14.6...
Configuring th-reify-many-0.1.8...
Installed memory-0.14.6
Building th-reify-many-0.1.8...
Configuring QuickCheck-2.10.0.1...
Installed th-reify-many-0.1.8
Building QuickCheck-2.10.0.1...
Configuring scientific-0.3.5.2...
Installed vector-0.12.0.1
Building scientific-0.3.5.2...
Configuring unordered-containers-0.2.8.0...
Installed scientific-0.3.5.2
Building unordered-containers-0.2.8.0...
Configuring constraints-0.9.1...
Installed unordered-containers-0.2.8.0
Building constraints-0.9.1...
Installed QuickCheck-2.10.0.1
Configuring th-lift-instances-0.1.11...
Building th-lift-instances-0.1.11...
Configuring cryptonite-0.24...
Installed th-lift-instances-0.1.11
Building cryptonite-0.24...
Configuring charset-0.3.7.1...
Installed constraints-0.9.1
Building charset-0.3.7.1...
Configuring attoparsec-0.13.2.0...
Installed charset-0.3.7.1
Building attoparsec-0.13.2.0...
Configuring th-orphans-0.13.4...
Installed attoparsec-0.13.2.0
Building th-orphans-0.13.4...
Configuring parsers-0.12.7...
Installed th-orphans-0.13.4
Building parsers-0.12.7...
Warning: /tmp/pkgConf-parsers-0.1217132582701573363368.7: Unrecognized field
dynamic-library-dirs on line 28
Installed parsers-0.12.7
Configuring th-desugar-1.6...
Building th-desugar-1.6...
Installed cryptonite-0.24
Configuring cryptohash-0.11.9...
Building cryptohash-0.11.9...
Installed cryptohash-0.11.9
Configuring inline-c-0.5.6.1...
Building inline-c-0.5.6.1...
Installed th-desugar-1.6
Configuring singletons-2.2...
Building singletons-2.2...
Installed inline-c-0.5.6.1
Installed singletons-2.2
Configuring jni-0.4.0...
Failed to install jni-0.4.0
Build log ( /home/builder/.cabal/logs/jni-0.4.0.log ):
cabal: Entering directory '/tmp/cabal-tmp-3118/jni-0.4.0'
Configuring jni-0.4.0...
cabal: Missing dependency on a foreign library:
* Missing C library: jvm
This problem can usually be solved by installing the system package that
provides this library (you may need the "-dev" version). If the library is
already installed but in a non-standard location then you can use the flags
--extra-include-dirs= and --extra-lib-dirs= to specify where it is.
cabal: Leaving directory '/tmp/cabal-tmp-3118/jni-0.4.0'
cabal: Error: some packages failed to install:
jni-0.4.0 failed during the configure step. The exception was:
ExitFailure 1