Build #1 for katydid-0.3.0.1

[all reports]

Package katydid-0.3.0.1
Install BuildFailed
Docs NotTried
Tests NotTried
Time submitted 2018-05-09 06:20:35.523002863 UTC
Compiler ghc-8.2.2
OS linux
Arch x86_64
Dependencies base-4.10.1.0, bytestring-0.10.8.2, containers-0.5.10.2, deepseq-1.4.3.0, either-5, extra-1.6.6, hxt-9.3.1.16, ilist-0.3.1.0, json-0.9.2, mtl-2.2.1, parsec-3.1.11, regex-tdfa-1.2.3, text-1.2.2.2, transformers-either-0.1.0, base-4.10.1.0, mtl-2.2.1
Flags none

Code Coverage

No Code Coverage was submitted for this report.

Build log

[view raw]

Resolving dependencies...
Configuring cabal-doctest-1.0.6...
Configuring base-orphans-0.7...
Building base-orphans-0.7...
Building cabal-doctest-1.0.6...
Installed base-orphans-0.7
Configuring clock-0.7.2...
Installed cabal-doctest-1.0.6
Configuring hxt-charproperties-9.2.0.1...
Building clock-0.7.2...
Building hxt-charproperties-9.2.0.1...
Installed clock-0.7.2
Configuring ilist-0.3.1.0...
Building ilist-0.3.1.0...
Installed ilist-0.3.1.0
Configuring json-0.9.2...
Building json-0.9.2...
Installed hxt-charproperties-9.2.0.1
Configuring regex-tdfa-1.2.3...
Building regex-tdfa-1.2.3...
Installed json-0.9.2
Configuring semigroups-0.18.4...
Building semigroups-0.18.4...
Installed semigroups-0.18.4
Configuring th-abstraction-0.2.6.0...
Building th-abstraction-0.2.6.0...
Installed th-abstraction-0.2.6.0
Configuring transformers-compat-0.6.1.5...
Building transformers-compat-0.6.1.5...
Installed transformers-compat-0.6.1.5
Configuring extra-1.6.6...
Building extra-1.6.6...
Installed regex-tdfa-1.2.3
Configuring hxt-unicode-9.0.2.4...
Building hxt-unicode-9.0.2.4...
Installed hxt-unicode-9.0.2.4
Configuring hxt-regex-xmlschema-9.2.0.3...
Installed extra-1.6.6
Configuring tagged-0.8.5...
Building hxt-regex-xmlschema-9.2.0.3...
Building tagged-0.8.5...
Installed tagged-0.8.5
Configuring exceptions-0.8.3...
Building exceptions-0.8.3...
Installed hxt-regex-xmlschema-9.2.0.3
Configuring contravariant-1.4.1...
Building contravariant-1.4.1...
Installed exceptions-0.8.3
Configuring distributive-0.5.3...
Installed contravariant-1.4.1
Configuring hxt-9.3.1.16...
Building hxt-9.3.1.16...
Building distributive-0.5.3...
Installed distributive-0.5.3
Configuring transformers-either-0.1.0...
Building transformers-either-0.1.0...
Installed transformers-either-0.1.0
Configuring comonad-5.0.3...
Building comonad-5.0.3...
Installed comonad-5.0.3
Configuring bifunctors-5.5.2...
Building bifunctors-5.5.2...
Installed bifunctors-5.5.2
Configuring semigroupoids-5.2.2...
Building semigroupoids-5.2.2...
Installed semigroupoids-5.2.2
Configuring profunctors-5.2.2...
Building profunctors-5.2.2...
Installed hxt-9.3.1.16
Installed profunctors-5.2.2
Configuring either-5...
Building either-5...
Installed either-5
Downloading katydid-0.3.0.1...
Configuring katydid-0.3.0.1...
Building katydid-0.3.0.1...
Failed to install katydid-0.3.0.1
Build log ( /home/builder/.cabal/logs/ghc-8.2.2/katydid-0.3.0.1-3eytza2nsDQHH2MsQtGcvI.log ):
cabal: Entering directory '/tmp/cabal-tmp-15705/katydid-0.3.0.1'
Configuring katydid-0.3.0.1...
Preprocessing library for katydid-0.3.0.1..
Building library for katydid-0.3.0.1..
[ 1 of 23] Compiling Parsers          ( src/Parsers.hs, dist/build/Parsers.o )
[ 2 of 23] Compiling Json             ( src/Json.hs, dist/build/Json.o )
[ 3 of 23] Compiling Expr             ( src/Expr.hs, dist/build/Expr.o )

src/Expr.hs:279:39: error:
    • Variable not in scope: (<>) :: Ordering -> Ordering -> t2
    • Perhaps you meant one of these:
        ‘<$>’ (imported from Prelude), ‘*>’ (imported from Prelude),
        ‘<$’ (imported from Prelude)
    |
279 | cmp a b = compare (_hash a) (_hash b) <>
    |                                       ^^

src/Expr.hs:280:33: error:
    • Variable not in scope: (<>) :: t2 -> Ordering -> t1
    • Perhaps you meant one of these:
        ‘<$>’ (imported from Prelude), ‘*>’ (imported from Prelude),
        ‘<$’ (imported from Prelude)
    |
280 |     compare (_name a) (_name b) <>
    |                                 ^^

src/Expr.hs:281:55: error:
    • Variable not in scope: (<>) :: t1 -> Ordering -> t0
    • Perhaps you meant one of these:
        ‘<$>’ (imported from Prelude), ‘*>’ (imported from Prelude),
        ‘<$’ (imported from Prelude)
    |
281 |     compare (length (_params a)) (length (_params b)) <>
    |                                                       ^^

src/Expr.hs:282:11: error:
    • Variable not in scope: (<>) :: Ordering -> Ordering -> Ordering
    • Perhaps you meant one of these:
        ‘<$>’ (imported from Prelude), ‘*>’ (imported from Prelude),
        ‘<$’ (imported from Prelude)
    |
282 |     foldl (<>) EQ (zipWith cmp (_params a) (_params b)) <>
    |           ^^^^

src/Expr.hs:282:57: error:
    • Variable not in scope: (<>) :: t0 -> Ordering -> Ordering
    • Perhaps you meant one of these:
        ‘<$>’ (imported from Prelude), ‘*>’ (imported from Prelude),
        ‘<$’ (imported from Prelude)
    |
282 |     foldl (<>) EQ (zipWith cmp (_params a) (_params b)) <>
    |                                                         ^^
cabal: Leaving directory '/tmp/cabal-tmp-15705/katydid-0.3.0.1'
cabal: Error: some packages failed to install:
katydid-0.3.0.1-3eytza2nsDQHH2MsQtGcvI failed during the building phase. The
exception was:
ExitFailure 1