Build #6 for kit-0.5

[all reports]

Package kit-0.5
Install BuildFailed
Docs NotTried
Tests NotTried
Time submitted 2016-12-28 17:38:03.514998 UTC
Compiler ghc-8.0.1.20161018
OS linux
Arch x86_64
Dependencies Glob-0.7.13, HTTP-4000.3.3, QuickCheck-2.9.2, base-4.9.0.0, bytestring-0.10.8.1, cmdargs-0.10.14, containers-0.5.7.1, directory-1.2.6.2, filepath-1.4.1.0, json-0.9.1, mtl-2.2.1, network-2.6.3.1, process-1.4.2.0
Flags none

Code Coverage

No Code Coverage was submitted for this report.

Build log

[view raw]

Resolving dependencies...
Configuring dlist-0.8.0.2...
Configuring cmdargs-0.10.14...
Building dlist-0.8.0.2...
Building cmdargs-0.10.14...
Installed dlist-0.8.0.2
Configuring mtl-2.2.1...
Building mtl-2.2.1...
Configuring network-2.6.3.1...
Installed mtl-2.2.1
Building network-2.6.3.1...
Configuring random-1.1...
Installed network-2.6.3.1
Building random-1.1...
Configuring primitive-0.6.2.0...
Installed cmdargs-0.10.14
Building primitive-0.6.2.0...
Configuring syb-0.6...
Installed random-1.1
Building syb-0.6...
Configuring transformers-compat-0.5.1.4...
Installed syb-0.6
Configuring text-1.2.2.1...
Installed primitive-0.6.2.0
Building transformers-compat-0.5.1.4...
Building text-1.2.2.1...
Installed transformers-compat-0.5.1.4
Configuring tf-random-0.5...
Building tf-random-0.5...
Configuring Glob-0.7.13...
Installed tf-random-0.5
Building Glob-0.7.13...
Installed Glob-0.7.13
Configuring QuickCheck-2.9.2...
Building QuickCheck-2.9.2...
Installed text-1.2.2.1
Configuring parsec-3.1.11...
Building parsec-3.1.11...
Installed parsec-3.1.11
Configuring network-uri-2.6.1.0...
Building network-uri-2.6.1.0...
Configuring json-0.9.1...
Installed network-uri-2.6.1.0
Building json-0.9.1...
Installed QuickCheck-2.9.2
Configuring HTTP-4000.3.3...
Building HTTP-4000.3.3...
Installed json-0.9.1
Installed HTTP-4000.3.3
Downloading kit-0.5...
Configuring kit-0.5...
Building kit-0.5...
Failed to install kit-0.5
Build log ( /home/builder/.cabal/logs/kit-0.5.log ):
cabal: Entering directory '/tmp/cabal-tmp-26811/kit-0.5'
Configuring kit-0.5...
Building kit-0.5...
Preprocessing executable 'kit' for kit-0.5...
[ 1 of 12] Compiling Text.PList       ( Text/PList.hs, dist/build/kit/kit-tmp/Text/PList.o )
[ 2 of 12] Compiling Kit.XCode.Common ( Kit/XCode/Common.hs, dist/build/kit/kit-tmp/Kit/XCode/Common.o )
[ 3 of 12] Compiling Kit.XCode.ProjectFileTemplate ( Kit/XCode/ProjectFileTemplate.hs, dist/build/kit/kit-tmp/Kit/XCode/ProjectFileTemplate.o )

Kit/XCode/ProjectFileTemplate.hs:55:5: warning: [-Wtabs]
    Tab character found here, and in 307 further locations.
    Please use spaces instead.
[ 4 of 12] Compiling Kit.Util         ( Kit/Util.hs, dist/build/kit/kit-tmp/Kit/Util.o )

Kit/Util.hs:35:12: error:
    Duplicate instance declarations:
      instance Foldable (Either c) -- Defined at Kit/Util.hs:35:12
      instance Foldable (Either a) -- Defined in ‘Data.Foldable’

Kit/Util.hs:38:12: error:
    Duplicate instance declarations:
      instance Traversable (Either c) -- Defined at Kit/Util.hs:38:12
      instance Traversable (Either a) -- Defined in ‘Data.Traversable’
cabal: Leaving directory '/tmp/cabal-tmp-26811/kit-0.5'
cabal: Error: some packages failed to install:
kit-0.5 failed during the building phase. The exception was:
ExitFailure 1