Build #8 for linkcore-0.4.1

[all reports]

Package linkcore-0.4.1
Install DependencyFailed extcore-1.0.2
Docs NotTried
Tests NotTried
Time submitted 2016-12-29 21:05:49.816674 UTC
Compiler ghc-8.0.1.20161018
OS linux
Arch x86_64
Dependencies base-4.9.0.0, containers-0.5.7.1, extcore-1.0.2, filepath-1.4.1.0, process-1.4.2.0
Flags none

Code Coverage

No Code Coverage was submitted for this report.

Build log

[view raw]

Resolving dependencies...
Configuring mtl-2.2.1...
Configuring syb-0.6...
Building mtl-2.2.1...
Building syb-0.6...
Configuring text-1.2.2.1...
Installed syb-0.6
Installed mtl-2.2.1
Building text-1.2.2.1...
Installed text-1.2.2.1
Configuring parsec-3.1.11...
Building parsec-3.1.11...
Installed parsec-3.1.11
Configuring extcore-1.0.2...
Building extcore-1.0.2...
Failed to install extcore-1.0.2
Build log ( /home/builder/.cabal/logs/extcore-1.0.2.log ):
cabal: Entering directory '/tmp/cabal-tmp-29275/extcore-1.0.2'
Configuring extcore-1.0.2...
Building extcore-1.0.2...
Preprocessing library extcore-1.0.2...

Language/Core/Interp.hs:1:12: warning:
    -fglasgow-exts is deprecated: Use individual extensions instead
[ 1 of 21] Compiling Language.Core.Utils ( Language/Core/Utils.hs, dist/build/Language/Core/Utils.o )

Language/Core/Utils.hs:26:15: warning: [-Wname-shadowing]
    This binding for ‘empty’ shadows the existing binding
      imported from ‘Data.Generics’ at Language/Core/Utils.hs:6:1-20
      (and originally defined in ‘Data.Generics.Builders’)
[ 2 of 21] Compiling Language.Core.Env ( Language/Core/Env.hs, dist/build/Language/Core/Env.o )

Language/Core/Env.hs:7:1: warning: [-Wtabs]
    Tab character found here, and in four further locations.
    Please use spaces instead.
[ 3 of 21] Compiling Language.Core.Encoding ( Language/Core/Encoding.hs, dist/build/Language/Core/Encoding.o )

Language/Core/Encoding.hs:55:25: warning: [-Wtabs]
    Tab character found here, and in 35 further locations.
    Please use spaces instead.
[ 4 of 21] Compiling Language.Core.ParseGlue ( Language/Core/ParseGlue.hs, dist/build/Language/Core/ParseGlue.o )
[ 5 of 21] Compiling Language.Core.Lex ( Language/Core/Lex.hs, dist/build/Language/Core/Lex.o )
[ 6 of 21] Compiling Language.Core.Core ( Language/Core/Core.hs, dist/build/Language/Core/Core.o )

Language/Core/Core.hs:41:18: warning: [-Wtabs]
    Tab character found here, and in 11 further locations.
    Please use spaces instead.
[ 7 of 21] Compiling Language.Core.PrimCoercions ( Language/Core/PrimCoercions.hs, dist/build/Language/Core/PrimCoercions.o )
[ 8 of 21] Compiling Language.Core.PrimEnv ( Language/Core/PrimEnv.hs, dist/build/Language/Core/PrimEnv.o )
[ 9 of 21] Compiling Language.Core.Printer ( Language/Core/Printer.hs, dist/build/Language/Core/Printer.o )

Language/Core/Printer.hs:66:1: warning: [-Wtabs]
    Tab character found here, and in 32 further locations.
    Please use spaces instead.
[10 of 21] Compiling Language.Core.CoreUtils ( Language/Core/CoreUtils.hs, dist/build/Language/Core/CoreUtils.o )

Language/Core/CoreUtils.hs:140:1: warning: [-Wtabs]
    Tab character found here.
    Please use spaces instead.
[11 of 21] Compiling Language.Core.Merge ( Language/Core/Merge.hs, dist/build/Language/Core/Merge.o )

Language/Core/Merge.hs:68:9: error:
    • Non type-variable argument
        in the constraint: MonadState (a, M.Map (Qual Var) (Qual [Char])) m
      (Use FlexibleContexts to permit this)
    • When checking the inferred type
        doOneVdef :: forall a (m :: * -> *).
                     (Show a, Num a,
                      MonadState (a, M.Map (Qual Var) (Qual [Char])) m) =>
                     Vdef -> m Vdef
      In an equation for ‘rnTopVdefgs’:
          rnTopVdefgs vds
            = mapM (mapVdefg doOneVdef) vds
            where
                doOneVdef (Vdef (qv@(Nothing, v), t, e))
                  = do { newUnique <- gets fst;
                         .... }
                doOneVdef vd = return vd
cabal: Leaving directory '/tmp/cabal-tmp-29275/extcore-1.0.2'
cabal: Error: some packages failed to install:
extcore-1.0.2 failed during the building phase. The exception was:
ExitFailure 1
linkcore-0.4.1 depends on extcore-1.0.2 which failed to install.