Dependencies for llvm-ffi-9.1.0

library
llvm-ffi-example
llvm-ffi-offset

Flags

NameDescriptionDefaultType
developer

developer mode - warnings let compilation fail

DisabledManual
buildexamples

Build example executables

DisabledManual
pkgconfig

use pkgconfig (llvm.pc) instead of extra-libraries

DisabledAutomatic
specificpkgconfig

use llvm-3.x.pc instead of llvm.pc

EnabledAutomatic
llvm309

use LLVM-3.9 instead of latest supported LLVM

DisabledAutomatic
llvm400

use LLVM-4.0 instead of latest supported LLVM

DisabledAutomatic
llvm500

use LLVM-5.0 instead of latest supported LLVM

DisabledAutomatic
llvm600

use LLVM-6.0 instead of latest supported LLVM

DisabledAutomatic
llvm700

use LLVM-7.0 instead of latest supported LLVM

DisabledAutomatic
llvm800

use LLVM-8.0 instead of latest supported LLVM

DisabledAutomatic

Use -f <flag> to enable a flag, or -f -<flag> to disable that flag. More info