Build #3 for mulang-3.6.0

[all reports]

Package mulang-3.6.0
Install DependencyFailed mulang-3.6.0
Docs NotTried
Tests NotTried
Time submitted 2018-01-03 20:28:25.395972465 UTC
Compiler ghc-8.2.2
OS linux
Arch x86_64
Dependencies ParsecTools-0.0.2.0, aeson-1.2.3.0, base-4.10.1.0, bytestring-0.10.8.2, containers-0.5.10.2, hashable-1.2.6.1, haskell-src-1.0.2.0, inflections-0.4.0.0, language-java-0.2.8, language-javascript-0.6.0.10, parsec-3.1.11, process-1.6.1.0, scientific-0.3.5.2, split-0.2.3.2, text-1.2.2.2, unordered-containers-0.2.8.0, vector-0.12.0.1, aeson-1.2.3.0, base-4.10.1.0, bytestring-0.10.8.2, neat-interpolation-0.3.2.1, process-1.6.1.0, text-1.2.2.2
Flags none

Build log

[view raw]

Resolving dependencies...
Configuring ParsecTools-0.0.2.0...
Configuring base-compat-0.9.3...
Building base-compat-0.9.3...
Building ParsecTools-0.0.2.0...
Installed ParsecTools-0.0.2.0
Configuring base-prelude-1.2.0.1...
Building base-prelude-1.2.0.1...
Installed base-compat-0.9.3
Configuring blaze-builder-0.4.0.2...
Installed base-prelude-1.2.0.1
Configuring dlist-0.8.0.3...
Building blaze-builder-0.4.0.2...
Building dlist-0.8.0.3...
Installed blaze-builder-0.4.0.2
Configuring old-locale-1.0.0.7...
Installed dlist-0.8.0.3
Configuring parser-combinators-0.4.0...
Building old-locale-1.0.0.7...
Building parser-combinators-0.4.0...
Installed old-locale-1.0.0.7
Configuring polyparse-1.12...
Building polyparse-1.12...
Installed parser-combinators-0.4.0
Configuring th-abstraction-0.2.6.0...
Building th-abstraction-0.2.6.0...
Installed th-abstraction-0.2.6.0
Configuring time-locale-compat-0.1.1.3...
Building time-locale-compat-0.1.1.3...
Installed time-locale-compat-0.1.1.3
Configuring transformers-compat-0.5.1.4...
Installed polyparse-1.12
Configuring utf8-string-1.0.1.1...
Building transformers-compat-0.5.1.4...
Building utf8-string-1.0.1.1...
Installed transformers-compat-0.5.1.4
Configuring uuid-types-1.0.3...
Building uuid-types-1.0.3...
Installed utf8-string-1.0.1.1
Configuring neat-interpolation-0.3.2.1...
Building neat-interpolation-0.3.2.1...
Installed uuid-types-1.0.3
Configuring old-time-1.1.0.3...
Building old-time-1.1.0.3...
Installed neat-interpolation-0.3.2.1
Configuring megaparsec-6.4.0...
Building megaparsec-6.4.0...
Installed old-time-1.1.0.3
Configuring tagged-0.8.5...
Building tagged-0.8.5...
Installed tagged-0.8.5
Configuring exceptions-0.8.3...
Building exceptions-0.8.3...
Installed exceptions-0.8.3
Configuring language-javascript-0.6.0.10...
Installed megaparsec-6.4.0
Configuring cpphs-1.20.8...
Building language-javascript-0.6.0.10...
Building cpphs-1.20.8...
Installed cpphs-1.20.8
Configuring aeson-1.2.3.0...
Building aeson-1.2.3.0...
Installed language-javascript-0.6.0.10
Configuring inflections-0.4.0.0...
Building inflections-0.4.0.0...
Failed to install inflections-0.4.0.0
Build log ( /home/builder/.cabal/logs/ghc-8.2.2/inflections-0.4.0.0-5SbPrG8q2WhIqzpgNlphnq.log ):
cabal: Entering directory '/tmp/cabal-tmp-13062/inflections-0.4.0.0'
Configuring inflections-0.4.0.0...
Preprocessing library for inflections-0.4.0.0..
Building library for inflections-0.4.0.0..
[ 1 of 13] Compiling Text.Inflections.Data ( Text/Inflections/Data.hs, dist/build/Text/Inflections/Data.o )
[ 2 of 13] Compiling Text.Inflections.Ordinal ( Text/Inflections/Ordinal.hs, dist/build/Text/Inflections/Ordinal.o )
[ 3 of 13] Compiling Text.Inflections.Parameterize ( Text/Inflections/Parameterize.hs, dist/build/Text/Inflections/Parameterize.o )
[ 4 of 13] Compiling Text.Inflections.Transliterate ( Text/Inflections/Transliterate.hs, dist/build/Text/Inflections/Transliterate.o )
[ 5 of 13] Compiling Text.Inflections.Types ( Text/Inflections/Types.hs, dist/build/Text/Inflections/Types.o )
[ 6 of 13] Compiling Text.Inflections.Titleize ( Text/Inflections/Titleize.hs, dist/build/Text/Inflections/Titleize.o )
[ 7 of 13] Compiling Text.Inflections.Parse.SnakeCase ( Text/Inflections/Parse/SnakeCase.hs, dist/build/Text/Inflections/Parse/SnakeCase.o )

Text/Inflections/Parse/SnakeCase.hs:62:19: error:
    Ambiguous occurrence ‘some’
    It could refer to either ‘Control.Applicative.some’,
                             imported from ‘Control.Applicative’ at Text/Inflections/Parse/SnakeCase.hs:19:1-26
                             (and originally defined in ‘GHC.Base’)
                          or ‘Text.Megaparsec.some’,
                             imported from ‘Text.Megaparsec’ at Text/Inflections/Parse/SnakeCase.hs:23:1-22
                             (and originally defined in ‘parser-combinators-0.4.0:Control.Monad.Combinators’)
   |
62 |   r <- T.pack <$> some alphaNumChar
   |                   ^^^^
cabal: Leaving directory '/tmp/cabal-tmp-13062/inflections-0.4.0.0'
Configuring language-java-0.2.8...
Building language-java-0.2.8...
Installed aeson-1.2.3.0
Installed language-java-0.2.8
cabal: Error: some packages failed to install:
inflections-0.4.0.0-5SbPrG8q2WhIqzpgNlphnq failed during the building phase.
The exception was:
ExitFailure 1
mulang-3.6.0-IaNsGJxsf5VHz1QH518htW depends on mulang-3.6.0 which failed to
install.