Build #3 for multiplicity-0.1.0

[all reports]

Package multiplicity-0.1.0
Install InstallOk
Docs Ok
Tests NotTried
Time submitted 2015-09-27 06:38:01.703914 UTC
Compiler ghc-7.10.2
OS linux
Arch x86_64
Dependencies process-1.2.3.0, mtl-2.2.1, fez-conf-1.0.3, containers-0.5.6.2, base-4.8.1.0
Flags none

Code Coverage

No Code Coverage was submitted for this report.

Build log

[view raw]

Resolving dependencies...
Configuring mtl-2.2.1...
Building mtl-2.2.1...
Preprocessing library mtl-2.2.1...
[ 1 of 22] Compiling Control.Monad.Writer.Class ( Control/Monad/Writer/Class.hs, dist/build/Control/Monad/Writer/Class.o )
[ 2 of 22] Compiling Control.Monad.State.Class ( Control/Monad/State/Class.hs, dist/build/Control/Monad/State/Class.o )
[ 3 of 22] Compiling Control.Monad.Reader.Class ( Control/Monad/Reader/Class.hs, dist/build/Control/Monad/Reader/Class.o )
[ 4 of 22] Compiling Control.Monad.RWS.Class ( Control/Monad/RWS/Class.hs, dist/build/Control/Monad/RWS/Class.o )
[ 5 of 22] Compiling Control.Monad.Identity ( Control/Monad/Identity.hs, dist/build/Control/Monad/Identity.o )
[ 6 of 22] Compiling Control.Monad.Error.Class ( Control/Monad/Error/Class.hs, dist/build/Control/Monad/Error/Class.o )
[ 7 of 22] Compiling Control.Monad.Cont.Class ( Control/Monad/Cont/Class.hs, dist/build/Control/Monad/Cont/Class.o )
[ 8 of 22] Compiling Control.Monad.Trans ( Control/Monad/Trans.hs, dist/build/Control/Monad/Trans.o )
[ 9 of 22] Compiling Control.Monad.Error ( Control/Monad/Error.hs, dist/build/Control/Monad/Error.o )
[10 of 22] Compiling Control.Monad.Except ( Control/Monad/Except.hs, dist/build/Control/Monad/Except.o )
[11 of 22] Compiling Control.Monad.List ( Control/Monad/List.hs, dist/build/Control/Monad/List.o )
[12 of 22] Compiling Control.Monad.RWS.Lazy ( Control/Monad/RWS/Lazy.hs, dist/build/Control/Monad/RWS/Lazy.o )
[13 of 22] Compiling Control.Monad.RWS ( Control/Monad/RWS.hs, dist/build/Control/Monad/RWS.o )
[14 of 22] Compiling Control.Monad.Reader ( Control/Monad/Reader.hs, dist/build/Control/Monad/Reader.o )
[15 of 22] Compiling Control.Monad.RWS.Strict ( Control/Monad/RWS/Strict.hs, dist/build/Control/Monad/RWS/Strict.o )
[16 of 22] Compiling Control.Monad.State.Lazy ( Control/Monad/State/Lazy.hs, dist/build/Control/Monad/State/Lazy.o )
[17 of 22] Compiling Control.Monad.State ( Control/Monad/State.hs, dist/build/Control/Monad/State.o )
[18 of 22] Compiling Control.Monad.State.Strict ( Control/Monad/State/Strict.hs, dist/build/Control/Monad/State/Strict.o )
[19 of 22] Compiling Control.Monad.Writer.Lazy ( Control/Monad/Writer/Lazy.hs, dist/build/Control/Monad/Writer/Lazy.o )
[20 of 22] Compiling Control.Monad.Writer ( Control/Monad/Writer.hs, dist/build/Control/Monad/Writer.o )
[21 of 22] Compiling Control.Monad.Writer.Strict ( Control/Monad/Writer/Strict.hs, dist/build/Control/Monad/Writer/Strict.o )
[22 of 22] Compiling Control.Monad.Cont ( Control/Monad/Cont.hs, dist/build/Control/Monad/Cont.o )
In-place registering mtl-2.2.1...
Running Haddock for mtl-2.2.1...
cabal: Haddock's internal GHC version must match the configured GHC version.
The GHC version is 7.10.2 but haddock is using GHC version 7.8.3
Creating package registration file: /tmp/pkgConf-mtl-2.2336465782861021530.1
Installing library in
/home/builder/hackage-server/build-cache/tmp-install/lib/x86_64-linux-ghc-7.10.2/mtl-2.2.1-KMpng31YRYc5JfMWFZ3FCU
Registering mtl-2.2.1...
Installed mtl-2.2.1
Configuring regex-base-0.93.2...
Building regex-base-0.93.2...
Preprocessing library regex-base-0.93.2...
[1 of 4] Compiling Text.Regex.Base.RegexLike ( Text/Regex/Base/RegexLike.hs, dist/build/Text/Regex/Base/RegexLike.o )
[2 of 4] Compiling Text.Regex.Base.Context ( Text/Regex/Base/Context.hs, dist/build/Text/Regex/Base/Context.o )
[3 of 4] Compiling Text.Regex.Base  ( Text/Regex/Base.hs, dist/build/Text/Regex/Base.o )

Text/Regex/Base.hs:55:13: Warning:
    In the use of ‘versionTags’ (imported from Data.Version):
    Deprecated: "See GHC ticket #2496"
[4 of 4] Compiling Text.Regex.Base.Impl ( Text/Regex/Base/Impl.hs, dist/build/Text/Regex/Base/Impl.o )
In-place registering regex-base-0.93.2...
Running Haddock for regex-base-0.93.2...
cabal: Haddock's internal GHC version must match the configured GHC version.
The GHC version is 7.10.2 but haddock is using GHC version 7.8.3
Creating package registration file:
/tmp/pkgConf-regex-base-0.931600515282040332871.2
Installing library in
/home/builder/hackage-server/build-cache/tmp-install/lib/x86_64-linux-ghc-7.10.2/regex-base-0.93.2-2j0nR3pc4q24HZdEmShSMX
Registering regex-base-0.93.2...
Installed regex-base-0.93.2
Configuring regex-posix-0.95.2...
Building regex-posix-0.95.2...
Preprocessing library regex-posix-0.95.2...
[1 of 6] Compiling Text.Regex.Posix.Wrap ( dist/build/Text/Regex/Posix/Wrap.hs, dist/build/Text/Regex/Posix/Wrap.o )
[2 of 6] Compiling Text.Regex.Posix.String ( Text/Regex/Posix/String.hs, dist/build/Text/Regex/Posix/String.o )
[3 of 6] Compiling Text.Regex.Posix.Sequence ( Text/Regex/Posix/Sequence.hs, dist/build/Text/Regex/Posix/Sequence.o )
[4 of 6] Compiling Text.Regex.Posix.ByteString ( Text/Regex/Posix/ByteString.hs, dist/build/Text/Regex/Posix/ByteString.o )
[5 of 6] Compiling Text.Regex.Posix.ByteString.Lazy ( Text/Regex/Posix/ByteString/Lazy.hs, dist/build/Text/Regex/Posix/ByteString/Lazy.o )
[6 of 6] Compiling Text.Regex.Posix ( Text/Regex/Posix.hs, dist/build/Text/Regex/Posix.o )

Text/Regex/Posix.hs:72:13: Warning:
    In the use of ‘versionTags’ (imported from Data.Version):
    Deprecated: "See GHC ticket #2496"
In-place registering regex-posix-0.95.2...
Running Haddock for regex-posix-0.95.2...
cabal: Haddock's internal GHC version must match the configured GHC version.
The GHC version is 7.10.2 but haddock is using GHC version 7.8.3
Creating package registration file:
/tmp/pkgConf-regex-posix-0.951476153275213975407.2
Installing library in
/home/builder/hackage-server/build-cache/tmp-install/lib/x86_64-linux-ghc-7.10.2/regex-posix-0.95.2-6Fv9CTZU9JMB52PT4YRZTl
Registering regex-posix-0.95.2...
Installed regex-posix-0.95.2
Configuring regex-compat-0.95.1...
Building regex-compat-0.95.1...
Preprocessing library regex-compat-0.95.1...
[1 of 1] Compiling Text.Regex       ( Text/Regex.hs, dist/build/Text/Regex.o )

Text/Regex.hs:50:1: Warning: Tab character

Text/Regex.hs:51:1: Warning: Tab character

Text/Regex.hs:63:12: Warning: Tab character

Text/Regex.hs:64:13: Warning: Tab character

Text/Regex.hs:65:21: Warning: Tab character

Text/Regex.hs:66:1: Warning: Tab character

Text/Regex.hs:67:1: Warning: Tab character

Text/Regex.hs:73:12: Warning: Tab character

Text/Regex.hs:74:13: Warning: Tab character

Text/Regex.hs:76:1: Warning: Tab character

Text/Regex.hs:77:1: Warning: Tab character

Text/Regex.hs:78:1: Warning: Tab character

Text/Regex.hs:79:1: Warning: Tab character

Text/Regex.hs:80:1: Warning: Tab character

Text/Regex.hs:81:1: Warning: Tab character
In-place registering regex-compat-0.95.1...
Running Haddock for regex-compat-0.95.1...
cabal: Haddock's internal GHC version must match the configured GHC version.
The GHC version is 7.10.2 but haddock is using GHC version 7.8.3
Creating package registration file:
/tmp/pkgConf-regex-compat-0.957407593551285228804.1
Installing library in
/home/builder/hackage-server/build-cache/tmp-install/lib/x86_64-linux-ghc-7.10.2/regex-compat-0.95.1-LfevtAmd1jA93E87NZxMhh
Registering regex-compat-0.95.1...
Installed regex-compat-0.95.1
Configuring fez-conf-1.0.3...
Building fez-conf-1.0.3...
Preprocessing library fez-conf-1.0.3...
[1 of 1] Compiling Fez.Data.Conf    ( src/Fez/Data/Conf.hs, dist/build/Fez/Data/Conf.o )
In-place registering fez-conf-1.0.3...
Running Haddock for fez-conf-1.0.3...
cabal: Haddock's internal GHC version must match the configured GHC version.
The GHC version is 7.10.2 but haddock is using GHC version 7.8.3
Creating package registration file:
/tmp/pkgConf-fez-conf-1.01473442062201305624.3
Installing library in
/home/builder/hackage-server/build-cache/tmp-install/lib/x86_64-linux-ghc-7.10.2/fez-conf-1.0.3-2PQzhVJCUdbBwgYjL3DIoj
Registering fez-conf-1.0.3...
Installed fez-conf-1.0.3
Configuring multiplicity-0.1.0...
Building multiplicity-0.1.0...
Preprocessing executable 'multiplicity' for multiplicity-0.1.0...
[1 of 4] Compiling Paths_multiplicity ( dist/build/autogen/Paths_multiplicity.hs, dist/build/multiplicity/multiplicity-tmp/Paths_multiplicity.o )
[2 of 4] Compiling Multiplicity.Common ( src/Multiplicity/Common.hs, dist/build/multiplicity/multiplicity-tmp/Multiplicity/Common.o )
[3 of 4] Compiling Multiplicity.Docs ( src/Multiplicity/Docs.hs, dist/build/multiplicity/multiplicity-tmp/Multiplicity/Docs.o )
[4 of 4] Compiling Main             ( src/main.hs, dist/build/multiplicity/multiplicity-tmp/Main.o )

src/main.hs:7:1: Warning:
    Module ‘Control.Monad.Error’ is deprecated:
      Use Control.Monad.Except instead

src/main.hs:11:1: Warning:
    Module ‘Fez.Data.Conf’ is deprecated:
      Use TCE.Data.KVConf from tce-conf instead

src/main.hs:25:16: Warning:
    In the use of type constructor or class ‘ConfMap’
    (imported from Fez.Data.Conf):
    Deprecated: "Use TCE.Data.KVConf from tce-conf instead"

src/main.hs:34:15: Warning:
    In the use of type constructor or class ‘ErrorT’
    (imported from Control.Monad.Error, but defined in transformers-0.4.2.0:Control.Monad.Trans.Error):
    Deprecated: "Use Control.Monad.Trans.Except instead"

src/main.hs:36:12: Warning:
    In the use of type constructor or class ‘ErrorT’
    (imported from Control.Monad.Error, but defined in transformers-0.4.2.0:Control.Monad.Trans.Error):
    Deprecated: "Use Control.Monad.Trans.Except instead"

src/main.hs:37:29: Warning:
    In the use of ‘runErrorT’
    (imported from Control.Monad.Error, but defined in transformers-0.4.2.0:Control.Monad.Trans.Error):
    Deprecated: "Use Control.Monad.Trans.Except instead"

src/main.hs:47:47: Warning:
    In the use of type constructor or class ‘ConfMap’
    (imported from Fez.Data.Conf):
    Deprecated: "Use TCE.Data.KVConf from tce-conf instead"

src/main.hs:178:24: Warning:
    In the use of ‘parseToMap’ (imported from Fez.Data.Conf):
    Deprecated: "Use TCE.Data.KVConf from tce-conf instead"
Linking dist/build/multiplicity/multiplicity ...
Warning: No documentation was generated as this package does not contain a
library. Perhaps you want to use the --executables, --tests or --benchmarks
flags.
Installing executable(s) in
/home/builder/hackage-server/build-cache/tmp-install/bin
Warning: The directory
/home/builder/hackage-server/build-cache/tmp-install/bin is not in the system
search path.
Installed multiplicity-0.1.0