Build #1 for mysql-simple-typed-0.1.2.0

[all reports]

Package mysql-simple-typed-0.1.2.0
Install DependencyFailed mysql-simple-typed-0.1.2.0
Docs NotTried
Tests NotTried
Time submitted 2019-06-12 15:08:18.246672472 UTC
Compiler ghc-8.6.3
OS linux
Arch x86_64
Dependencies base-4.12.0.0, mysql-0.1.7, mysql-simple-0.4.5, template-haskell-2.14.0.0, typedquery-0.1.1.2, utf8-string-1.0.1.1
Flags none

Code Coverage

No Code Coverage was submitted for this report.

Build log

[view raw]

Warning: The install command is a part of the legacy v1 style of cabal usage.

Please switch to using either the new project style and the new-install
command or the legacy v1-install alias as new-style projects will become the
default in the next version of cabal-install. Please file a bug if you cannot
replicate a working v1- use case with the new-style commands.

For more information, see: https://wiki.haskell.org/Cabal/NewBuild

Resolving dependencies...
Starting     base16-bytestring-0.1.1.6
Starting     dlist-0.8.0.6
Starting     blaze-builder-0.4.1.0
Starting     base-compat-0.9.3
Building     base16-bytestring-0.1.1.6
Building     dlist-0.8.0.6
Building     base-compat-0.9.3
Building     blaze-builder-0.4.1.0
Completed    base16-bytestring-0.1.1.6
Starting     hashable-1.3.0.0
Building     hashable-1.3.0.0
Completed    dlist-0.8.0.6
Starting     haskell-src-exts-1.21.0
Completed    base-compat-0.9.3
Starting     integer-logarithms-1.0.3
Completed    blaze-builder-0.4.1.0
Starting     mysql-0.1.7
Building     haskell-src-exts-1.21.0
Building     integer-logarithms-1.0.3
Completed    integer-logarithms-1.0.3
Starting     old-locale-1.0.0.7
Completed    hashable-1.3.0.0
Starting     pcre-light-0.4.0.4
Building     old-locale-1.0.0.7
Failed to install mysql-0.1.7
Build log ( /home/builder/.cabal/logs/ghc-8.6.3/mysql-0.1.7-2akJKk9UoN98FN0HKbIl2c.log ):
cabal: Entering directory '/tmp/cabal-tmp-21668/mysql-0.1.7'
[1 of 1] Compiling Main             ( /tmp/cabal-tmp-21668/mysql-0.1.7/dist/setup/setup.hs, /tmp/cabal-tmp-21668/mysql-0.1.7/dist/setup/Main.o )
Linking /tmp/cabal-tmp-21668/mysql-0.1.7/dist/setup/setup ...
Configuring mysql-0.1.7...
setup: The program 'mysql_config' is required but it could not be found

cabal: Leaving directory '/tmp/cabal-tmp-21668/mysql-0.1.7'
Starting     primitive-0.7.0.0
Building     pcre-light-0.4.0.4
Building     primitive-0.7.0.0
Completed    old-locale-1.0.0.7
Completed    pcre-light-0.4.0.4
Completed    primitive-0.7.0.0
Completed    haskell-src-exts-1.21.0
cabal: Error: some packages failed to install:
mysql-0.1.7-2akJKk9UoN98FN0HKbIl2c failed during the configure step. The
exception was:
ExitFailure 1
mysql-simple-0.4.5-CW885KCRNSpAa7rDqdPCvq depends on mysql-simple-0.4.5 which
failed to install.
mysql-simple-typed-0.1.2.0-EpcBwNBQHMgLFM8pJKiUZS depends on
mysql-simple-typed-0.1.2.0 which failed to install.