Build #3 for openapi-petstore-0.0.3.0

[all reports]

Package openapi-petstore-0.0.3.0
Install PlanningFailed
Docs NotTried
Tests NotTried
Time submitted 2018-11-23 04:46:50.4970346 UTC
Compiler ghc-8.6.1
OS linux
Arch x86_64
Dependencies
Flags none

Build log

[view raw]

Warning: The install command is a part of the legacy v1 style of cabal usage.

Please switch to using either the new project style and the new-install
command or the legacy v1-install alias as new-style projects will become the
default in the next version of cabal-install. Please file a bug if you cannot
replicate a working v1- use case with the new-style commands.

For more information, see: https://wiki.haskell.org/Cabal/NewBuild

Resolving dependencies...
cabal: Could not resolve dependencies:
[__0] trying: openapi-petstore-0.0.3.0 (user goal)
[__1] next goal: katip (dependency of openapi-petstore)
[__1] rejecting: katip-0.7.0.0, katip-0.6.3.0, katip-0.6.2.1, katip-0.6.2.0,
katip-0.6.1.0, katip-0.6.0.0 (conflict: openapi-petstore => katip>=0.4 &&
<0.6)
[__1] trying: katip-0.5.5.1
[__2] next goal: template-haskell (dependency of katip)
[__2] rejecting: template-haskell-2.14.0.0/installed-2.1... (conflict: katip
=> template-haskell>=2.8 && <2.14)
[__2] rejecting: template-haskell-2.14.0.0, template-haskell-2.13.0.0,
template-haskell-2.12.0.0, template-haskell-2.11.1.0,
template-haskell-2.11.0.0, template-haskell-2.10.0.0,
template-haskell-2.9.0.0, template-haskell-2.8.0.0, template-haskell-2.7.0.0,
template-haskell-2.6.0.0, template-haskell-2.5.0.0, template-haskell-2.4.0.1,
template-haskell-2.4.0.0, template-haskell-2.3.0.1, template-haskell-2.3.0.0,
template-haskell-2.2.0.0 (constraint from non-upgradeable package requires
installed instance)
[__2] fail (backjumping, conflict set: katip, template-haskell)
After searching the rest of the dependency tree exhaustively, these were the
goals I've had most trouble fulfilling: template-haskell, katip,
openapi-petstore