Build #8 for pappy-0.1.0.2

[all reports]

Package pappy-0.1.0.2
Install BuildFailed
Docs NotTried
Tests NotTried
Time submitted 2016-12-23 14:26:05.732865 UTC
Compiler ghc-8.0.1.20161018
OS linux
Arch x86_64
Dependencies base-4.9.0.0
Flags none

Code Coverage

No Code Coverage was submitted for this report.

Build log

[view raw]

Resolving dependencies...
Configuring pappy-0.1.0.2...
Building pappy-0.1.0.2...
Failed to install pappy-0.1.0.2
Build log ( /home/builder/.cabal/logs/pappy-0.1.0.2.log ):
cabal: Entering directory '/tmp/cabal-tmp-8888/pappy-0.1.0.2'
Configuring pappy-0.1.0.2...
Building pappy-0.1.0.2...
Preprocessing executable 'pappy' for pappy-0.1.0.2...
[1 of 9] Compiling Pos              ( src/Pos.hs, dist/build/pappy/pappy-tmp/Pos.o )

src/Pos.hs:8:1: warning: [-Wtabs]
    Tab character found here, and in 27 further locations.
    Please use spaces instead.
[2 of 9] Compiling Parse            ( src/Parse.hs, dist/build/pappy/pappy-tmp/Parse.o )

src/Parse.hs:39:10: error:
    • Could not deduce (Applicative (Parser d))
        arising from the superclasses of an instance declaration
      from the context: Derivs d
        bound by the instance declaration at src/Parse.hs:39:10-37
    • In the instance declaration for ‘Monad (Parser d)’
cabal: Leaving directory '/tmp/cabal-tmp-8888/pappy-0.1.0.2'
cabal: Error: some packages failed to install:
pappy-0.1.0.2 failed during the building phase. The exception was:
ExitFailure 1