Metadata revisions for prettyprinter-1.1

Package maintainers and Hackage trustees are allowed to edit certain bits of package metadata after a release, without uploading a new tarball. Note that the tarball itself is never changed, just the metadata that is stored separately. For more information about metadata revisions, please refer to the Hackage Metadata Revisions FAQ.

No. Time User SHA256
-r4 2019-09-10T11:15:37Z phadej 78617ce616d4e243ae367517683fd84ebbbd69a5d8d49358d796eed86a7ab2c2
  • Changed the library component's library dependency on 'base' from

    >=4.7 && <5
    to
    >=4.7 && <4.13

  • Changed the library component's library dependency on 'semigroups' from

    >=0.1 && <0.19
    to
    >=0.16.1 && <0.19

  • Changed the library component's library dependency on 'void' from

    -any
    to
    >=0.4 && <0.8

-r3 2017-07-29T14:49:20Z quchen 1d96a518eda2de06434ec215b7a728d6f56a008205a8da89bf9dafbe8a83d878
  • Changed the executable 'generate_readme' component's library dependency on 'template-haskell' from

    >=2.9 && <2.12
    to
    >=2.9

-r2 2017-07-27T07:52:28Z quchen d2042b3d313c8fe6225ad180db153fdd73bd70d03ec0981529aadb2c077bdd3d
  • Changed the test suite 'doctest' component's library dependency on 'doctest' from

    >=0.9 && <0.12
    to
    >=0.9

-r1 2017-06-16T07:15:13Z quchen bead6f9fcf9551e4470abee2830c3597e3e6439d016c97a28d371158ca1a6e2c
  • Changed the test suite 'testsuite' component's library dependency on 'tasty-quickcheck' from

    ==0.8.*
    to
    >=0.8 && <0.10

-r0 2017-06-08T07:12:44Z quchen 99f275a827bad3b7997f53a8efaa0626feaefe4d67a143fcd47154bdf1eb01fe