Build #7 for selenium-0.2.1

[all reports]

Package selenium-0.2.1
Install BuildFailed
Docs NotTried
Tests NotTried
Time submitted 2017-01-04 01:13:06.223977 UTC
Compiler ghc-8.0.1.20161018
OS linux
Arch x86_64
Dependencies HTTP-4000.3.4, HUnit-1.5.0.0, base-4.9.0.0, mtl-2.2.1, network-2.6.3.1
Flags none

Build log

[view raw]

Resolving dependencies...
Configuring call-stack-0.1.0...
Configuring mtl-2.2.1...
Building call-stack-0.1.0...
Building mtl-2.2.1...
Configuring network-2.6.3.1...
Installed call-stack-0.1.0
Configuring text-1.2.2.1...
Installed mtl-2.2.1
Building network-2.6.3.1...
Building text-1.2.2.1...
Installed network-2.6.3.1
Configuring HUnit-1.5.0.0...
Building HUnit-1.5.0.0...
Installed HUnit-1.5.0.0
Installed text-1.2.2.1
Configuring parsec-3.1.11...
Building parsec-3.1.11...
Installed parsec-3.1.11
Configuring network-uri-2.6.1.0...
Building network-uri-2.6.1.0...
Installed network-uri-2.6.1.0
Configuring HTTP-4000.3.4...
Building HTTP-4000.3.4...
Installed HTTP-4000.3.4
Configuring selenium-0.2.1...
Building selenium-0.2.1...
Failed to install selenium-0.2.1
Build log ( /home/builder/.cabal/logs/selenium-0.2.1.log ):
cabal: Entering directory '/tmp/cabal-tmp-27241/selenium-0.2.1'
[1 of 1] Compiling Main             ( /tmp/cabal-tmp-27241/selenium-0.2.1/dist/setup/setup.hs, /tmp/cabal-tmp-27241/selenium-0.2.1/dist/setup/Main.o )
Linking /tmp/cabal-tmp-27241/selenium-0.2.1/dist/setup/setup ...
Configuring selenium-0.2.1...
Warning: No 'build-type' specified. If you do not need a custom Setup.hs or
./configure script then use 'build-type: Simple'.
Warning: 'ghc-options: -prof' is not necessary and will lead to problems when
used on a library. Use the configure flag --enable-library-profiling and/or
--enable-profiling.
Building selenium-0.2.1...
Preprocessing library selenium-0.2.1...
[1 of 5] Compiling Selenium.Pretty  ( Selenium/Pretty.hs, dist/build/Selenium/Pretty.o )

Selenium/Pretty.hs:20:1: error:
    Failed to load interface for ‘Text.PrettyPrint’
    It is a member of the hidden package ‘pretty-1.1.3.3’.
    Perhaps you need to add ‘pretty’ to the build-depends in your .cabal file.
    Use -v to see a list of the files searched for.
cabal: Leaving directory '/tmp/cabal-tmp-27241/selenium-0.2.1'
cabal: Error: some packages failed to install:
selenium-0.2.1 failed during the building phase. The exception was:
ExitFailure 1