Build #3 for sparrow-0.0.3.1

[all reports]

Package sparrow-0.0.3.1
Install PlanningFailed
Docs NotTried
Tests NotTried
Time submitted 2018-11-28 07:56:45.12109654 UTC
Compiler ghc-8.6.1
OS linux
Arch x86_64
Dependencies
Flags none

Build log

[view raw]

Warning: The install command is a part of the legacy v1 style of cabal usage.

Please switch to using either the new project style and the new-install
command or the legacy v1-install alias as new-style projects will become the
default in the next version of cabal-install. Please file a bug if you cannot
replicate a working v1- use case with the new-style commands.

For more information, see: https://wiki.haskell.org/Cabal/NewBuild

Resolving dependencies...
cabal: Could not resolve dependencies:
[__0] trying: sparrow-0.0.3.1 (user goal)
[__1] trying: transformers-0.5.5.0/installed-0.5... (dependency of sparrow)
[__2] trying: purescript-iso-0.0.5 (dependency of sparrow)
[__3] next goal: zeromq4-haskell (dependency of purescript-iso)
[__3] rejecting: zeromq4-haskell-0.7.0, zeromq4-haskell-0.6.7,
zeromq4-haskell-0.6.6, zeromq4-haskell-0.6.5, zeromq4-haskell-0.6.4,
zeromq4-haskell-0.6.3, zeromq4-haskell-0.6.2, zeromq4-haskell-0.6.1,
zeromq4-haskell-0.6, zeromq4-haskell-0.5.1, zeromq4-haskell-0.5,
zeromq4-haskell-0.4.1, zeromq4-haskell-0.4, zeromq4-haskell-0.3.2,
zeromq4-haskell-0.3.1, zeromq4-haskell-0.3 (conflict: pkg-config package
libzmq>=4.0 && <5.0, not found in the pkg-config database)
[__3] trying: zeromq4-haskell-0.2
[__4] next goal: MonadCatchIO-transformers (dependency of zeromq4-haskell)
[__4] rejecting: MonadCatchIO-transformers-0.3.1.3 (conflict: transformers =>
base==4.12.0.0/installed-4.1..., MonadCatchIO-transformers => base<4.9)
[__4] rejecting: MonadCatchIO-transformers-0.3.1.2,
MonadCatchIO-transformers-0.3.1.1, MonadCatchIO-transformers-0.3.1.0
(conflict: transformers => base==4.12.0.0/installed-4.1...,
MonadCatchIO-transformers => base<4.8)
[__4] rejecting: MonadCatchIO-transformers-0.3.0.0,
MonadCatchIO-transformers-0.2.2.3, MonadCatchIO-transformers-0.2.2.2,
MonadCatchIO-transformers-0.2.2.1, MonadCatchIO-transformers-0.2.2.0,
MonadCatchIO-transformers-0.2.1.0, MonadCatchIO-transformers-0.2.0.0
(conflict: transformers => base==4.12.0.0/installed-4.1...,
MonadCatchIO-transformers => base<4.7)
[__4] rejecting: MonadCatchIO-transformers-0.1.0.1 (conflict:
transformers==0.5.5.0/installed-0.5..., MonadCatchIO-transformers =>
transformers==0.1.*)
[__4] rejecting: MonadCatchIO-transformers-0.1.0.0,
MonadCatchIO-transformers-0.0.2.0, MonadCatchIO-transformers-0.0.1.0
(conflict: transformers==0.5.5.0/installed-0.5..., MonadCatchIO-transformers
=> transformers<0.2)
[__4] fail (backjumping, conflict set: MonadCatchIO-transformers,
transformers, zeromq4-haskell)
After searching the rest of the dependency tree exhaustively, these were the
goals I've had most trouble fulfilling: base, MonadCatchIO-transformers,
transformers, sparrow, zeromq4-haskell, purescript-iso