Build #3 for sym-plot-0.3.0

[all reports]

Package sym-plot-0.3.0
Install DependencyFailed sym-0.12.1
Docs NotTried
Tests NotTried
Time submitted 2017-06-10 13:42:51.897188665 UTC
Compiler ghc-8.0.2
OS linux
Arch x86_64
Dependencies base-4.9.1.0, diagrams-cairo-1.4, diagrams-lib-1.4.1.1, sym-0.12.1
Flags none

Code Coverage

No Code Coverage was submitted for this report.

Build log

[view raw]

Resolving dependencies...
Configuring ansi-terminal-0.6.3.1...
Configuring base-orphans-0.6...
Building ansi-terminal-0.6.3.1...
Building base-orphans-0.6...
Installed base-orphans-0.6
Configuring cabal-doctest-1.0.2...
Building cabal-doctest-1.0.2...
Installed ansi-terminal-0.6.3.1
Configuring cereal-0.5.4.0...
Building cereal-0.5.4.0...
Configuring colour-2.3.3...
Installed cabal-doctest-1.0.2
Building colour-2.3.3...
Configuring data-default-class-0.1.2.0...
Installed cereal-0.5.4.0
Building data-default-class-0.1.2.0...
Configuring diagrams-solve-0.1.0.1...
Installed data-default-class-0.1.2.0
Configuring fingertree-0.1.1.0...
Installed colour-2.3.3
Building diagrams-solve-0.1.0.1...
Building fingertree-0.1.1.0...
Configuring fail-4.9.0.0...
Installed diagrams-solve-0.1.0.1
Building fail-4.9.0.0...
Configuring groups-0.4.0.0...
Installed fail-4.9.0.0
Building groups-0.4.0.0...
Configuring integer-logarithms-1.0.1...
Installed fingertree-0.1.1.0
Configuring newtype-0.2...
Installed groups-0.4.0.0
Building integer-logarithms-1.0.1...
Building newtype-0.2...
Configuring mtl-2.2.1...
Installed newtype-0.2
Configuring prelude-extras-0.4.0.3...
Installed integer-logarithms-1.0.1
Building mtl-2.2.1...
Building prelude-extras-0.4.0.3...
Configuring parallel-3.2.1.1...
Installed mtl-2.2.1
Configuring random-1.1...
Installed prelude-extras-0.4.0.3
Building parallel-3.2.1.1...
Building random-1.1...
Configuring primitive-0.6.2.0...
Installed parallel-3.2.1.1
Building primitive-0.6.2.0...
Configuring semigroups-0.18.3...
Installed random-1.1
Building semigroups-0.18.3...
Configuring reflection-2.1.2...
Installed semigroups-0.18.3
Building reflection-2.1.2...
Configuring split-0.2.3.2...
Installed primitive-0.6.2.0
Building split-0.2.3.2...
Configuring stm-2.4.4.1...
Installed reflection-2.1.2
Building stm-2.4.4.1...
Configuring th-abstraction-0.2.1.0...
Installed split-0.2.3.2
Building th-abstraction-0.2.1.0...
Configuring text-1.2.2.2...
Installed stm-2.4.4.1
Building text-1.2.2.2...
Configuring transformers-compat-0.5.1.4...
Installed th-abstraction-0.2.1.0
Building transformers-compat-0.5.1.4...
Configuring unix-compat-0.4.3.1...
Installed transformers-compat-0.5.1.4
Building unix-compat-0.4.3.1...
Configuring utf8-string-1.0.1.1...
Installed unix-compat-0.4.3.1
Building utf8-string-1.0.1.1...
Configuring void-0.7.2...
Installed utf8-string-1.0.1.1
Building void-0.7.2...
Configuring zlib-0.6.1.2...
Installed void-0.7.2
Building zlib-0.6.1.2...
Installed text-1.2.2.2
Configuring ansi-wl-pprint-0.6.7.3...
Building ansi-wl-pprint-0.6.7.3...
Configuring vector-0.12.0.1...
Installed zlib-0.6.1.2
Building vector-0.12.0.1...
Installed ansi-wl-pprint-0.6.7.3
Configuring async-2.1.1.1...
Building async-2.1.1.1...
Configuring StateVar-1.1.0.4...
Installed async-2.1.1.1
Building StateVar-1.1.0.4...
Configuring statestack-0.2.0.5...
Installed StateVar-1.1.0.4
Building statestack-0.2.0.5...
Configuring exceptions-0.8.3...
Installed statestack-0.2.0.5
Building exceptions-0.8.3...
Configuring tagged-0.8.5...
Installed exceptions-0.8.3
Building tagged-0.8.5...
Installed tagged-0.8.5
Configuring hashable-1.2.6.0...
Building hashable-1.2.6.0...
Installed hashable-1.2.6.0
Configuring optparse-applicative-0.13.2.0...
Building optparse-applicative-0.13.2.0...
Configuring hinotify-0.3.9...
Installed vector-0.12.0.1
Building hinotify-0.3.9...
Installed optparse-applicative-0.13.2.0
Configuring contravariant-1.4...
Building contravariant-1.4...
Configuring distributive-0.5.2...
Installed hinotify-0.3.9
Installed contravariant-1.4
Configuring unordered-containers-0.2.8.0...
Building unordered-containers-0.2.8.0...
Building distributive-0.5.2...
Warning: /tmp/pkgConf-distributive-0.519607098591760281936.2: Unrecognized
field dynamic-library-dirs on line 22
Installed distributive-0.5.2
Configuring JuicyPixels-3.2.8.1...
Building JuicyPixels-3.2.8.1...
Configuring hashtables-1.2.1.1...
Installed unordered-containers-0.2.8.0
Building hashtables-1.2.1.1...
Configuring scientific-0.3.4.15...
Installed hashtables-1.2.1.1
Building scientific-0.3.4.15...
Configuring sym-0.12.1...
Installed scientific-0.3.4.15
Building sym-0.12.1...
Configuring fsnotify-0.2.1...
Failed to install sym-0.12.1
Build log ( /home/builder/.cabal/logs/sym-0.12.1.log ):
cabal: Entering directory '/tmp/cabal-tmp-28946/sym-0.12.1'
Configuring sym-0.12.1...
Building sym-0.12.1...
Preprocessing library sym-0.12.1...
[ 1 of 20] Compiling Sym.Internal.Util ( Sym/Internal/Util.hs, dist/build/Sym/Internal/Util.o )
[ 2 of 20] Compiling Sym.Internal.Size ( Sym/Internal/Size.hs, dist/build/Sym/Internal/Size.o )
[ 3 of 20] Compiling Sym.Internal.CLongArray ( Sym/Internal/CLongArray.hs, dist/build/Sym/Internal/CLongArray.o )
[ 4 of 20] Compiling Sym.Internal.SubSeq ( Sym/Internal/SubSeq.hs, dist/build/Sym/Internal/SubSeq.o )
[ 5 of 20] Compiling Sym.Perm         ( Sym/Perm.hs, dist/build/Sym/Perm.o )
[ 6 of 20] Compiling Sym.Perm.Bijection ( Sym/Perm/Bijection.hs, dist/build/Sym/Perm/Bijection.o )
[ 7 of 20] Compiling Sym.Perm.D8      ( Sym/Perm/D8.hs, dist/build/Sym/Perm/D8.o )
[ 8 of 20] Compiling Sym.Perm.Component ( Sym/Perm/Component.hs, dist/build/Sym/Perm/Component.o )
[ 9 of 20] Compiling Sym.Perm.Group   ( Sym/Perm/Group.hs, dist/build/Sym/Perm/Group.o )
[10 of 20] Compiling Sym.Perm.MeshPattern ( Sym/Perm/MeshPattern.hs, dist/build/Sym/Perm/MeshPattern.o )
[11 of 20] Compiling Sym.Perm.Pattern ( Sym/Perm/Pattern.hs, dist/build/Sym/Perm/Pattern.o )
[12 of 20] Compiling Sym.Perm.SSYT    ( Sym/Perm/SSYT.hs, dist/build/Sym/Perm/SSYT.o )
[13 of 20] Compiling Sym.Perm.Simple  ( Sym/Perm/Simple.hs, dist/build/Sym/Perm/Simple.o )
[14 of 20] Compiling Sym.Perm.Sort    ( Sym/Perm/Sort.hs, dist/build/Sym/Perm/Sort.o )
[15 of 20] Compiling Sym.Perm.Stat    ( Sym/Perm/Stat.hs, dist/build/Sym/Perm/Stat.o )
[16 of 20] Compiling Sym.Permgram     ( Sym/Permgram.hs, dist/build/Sym/Permgram.o )

Sym/Permgram.hs:26:1: warning: [-Wunused-imports]
    The import of ‘Control.Applicative’ is redundant
      except perhaps to import instances from ‘Control.Applicative’
    To import instances alone, use: import Control.Applicative()
[17 of 20] Compiling Sym.Perm.Constructions ( Sym/Perm/Constructions.hs, dist/build/Sym/Perm/Constructions.o )
[18 of 20] Compiling Sym.Perm.Class   ( Sym/Perm/Class.hs, dist/build/Sym/Perm/Class.o )
[19 of 20] Compiling Sym.Perm.Meta    ( Sym/Perm/Meta.hs, dist/build/Sym/Perm/Meta.o )
[20 of 20] Compiling Sym              ( Sym.hs, dist/build/Sym.o )

Sym.hs:94:5: error:
    • Constraint ‘Permutation a’ in the type of ‘unst’
        constrains only the class type variables
      Use ConstrainedClassMethods to allow it
    • When checking the class method:
        unst :: forall a. (Permutation a, Permutation a) => Perm -> a
      In the class declaration for ‘Permutation’
cabal: Leaving directory '/tmp/cabal-tmp-28946/sym-0.12.1'
Building fsnotify-0.2.1...
Installed fsnotify-0.2.1
Configuring intervals-0.8...
Building intervals-0.8...
Configuring comonad-5.0.1...
Installed JuicyPixels-3.2.8.1
Building comonad-5.0.1...
Warning: /tmp/pkgConf-intervals-01909002904165344818.8: Unrecognized field
dynamic-library-dirs on line 27
Configuring gtk2hs-buildtools-0.13.2.2...
Installed intervals-0.8
Building gtk2hs-buildtools-0.13.2.2...
Warning: /tmp/pkgConf-comonad-5.01395235128532670688.1: Unrecognized field
dynamic-library-dirs on line 29
Configuring bytes-0.15.3...
Installed comonad-5.0.1
Building bytes-0.15.3...
Warning: /tmp/pkgConf-bytes-0.15706043324496987743.3: Unrecognized field
dynamic-library-dirs on line 23
Installed bytes-0.15.3
Configuring bifunctors-5.4.2...
Building bifunctors-5.4.2...
Installed bifunctors-5.4.2
Configuring profunctors-5.2...
Building profunctors-5.2...
Configuring semigroupoids-5.2...
Installed profunctors-5.2
Installed gtk2hs-buildtools-0.13.2.2
Configuring glib-0.13.4.1...
Building semigroupoids-5.2...
Building glib-0.13.4.1...
Warning: /tmp/pkgConf-semigroupoids-51034949299654887343.2: Unrecognized field
dynamic-library-dirs on line 60
Configuring cairo-0.13.3.1...
Installed semigroupoids-5.2
Building cairo-0.13.3.1...
Warning: /tmp/pkgConf-cairo-0.13.38890233111494613810.1: Unrecognized field
dynamic-library-dirs on line 39
Installed cairo-0.13.3.1
Configuring free-4.12.4...
Warning: /tmp/pkgConf-glib-0.13.414472676051369321801.1: Unrecognized field
dynamic-library-dirs on line 32
Configuring monoid-extras-0.4.2...
Installed glib-0.13.4.1
Building free-4.12.4...
Building monoid-extras-0.4.2...
Installed monoid-extras-0.4.2
Configuring pango-0.13.3.1...
Building pango-0.13.3.1...
Configuring dual-tree-0.2.0.9...
Installed free-4.12.4
Building dual-tree-0.2.0.9...
Installed dual-tree-0.2.0.9
Configuring adjunctions-4.3...
Building adjunctions-4.3...
Installed adjunctions-4.3
Configuring kan-extensions-5.0.2...
Building kan-extensions-5.0.2...
Installed kan-extensions-5.0.2
Configuring lens-4.15.3...
Building lens-4.15.3...
Warning: /tmp/pkgConf-pango-0.13.3404158660937370163.1: Unrecognized field
dynamic-library-dirs on line 33
Installed pango-0.13.3.1
Warning: /tmp/pkgConf-lens-4.1520586571991973387981.3: Unrecognized field
dynamic-library-dirs on line 122
Installed lens-4.15.3
Configuring linear-1.20.6...
Building linear-1.20.6...
Warning: /tmp/pkgConf-linear-1.2020251871901967681095.6: Unrecognized field
dynamic-library-dirs on line 26
Installed linear-1.20.6
Configuring active-0.2.0.13...
Configuring diagrams-core-1.4...
Building diagrams-core-1.4...
Building active-0.2.0.13...
Installed active-0.2.0.13
Installed diagrams-core-1.4
Configuring diagrams-lib-1.4.1.1...
Building diagrams-lib-1.4.1.1...
Installed diagrams-lib-1.4.1.1
Configuring diagrams-cairo-1.4...
Building diagrams-cairo-1.4...
Installed diagrams-cairo-1.4
cabal: Error: some packages failed to install:
sym-0.12.1 failed during the building phase. The exception was:
ExitFailure 1
sym-plot-0.3.0 depends on sym-0.12.1 which failed to install.