Build #3 for threepenny-gui-contextmenu-0.1.0.0

[all reports]

Package threepenny-gui-contextmenu-0.1.0.0
Install BuildFailed
Docs NotTried
Tests NotTried
Time submitted 2017-01-24 20:55:54.769258 UTC
Compiler ghc-8.0.1.20161018
OS linux
Arch x86_64
Dependencies base-4.9.0.0, threepenny-gui-0.7.0.0, base-4.9.0.0, threepenny-gui-0.7.0.0
Flags none

Build log

[view raw]

Resolving dependencies...
Configuring SHA-1.6.4.2...
Configuring base64-bytestring-1.0.0.1...
Building base64-bytestring-1.0.0.1...
Building SHA-1.6.4.2...
Configuring base-compat-0.9.1...
Installed base64-bytestring-1.0.0.1
Building base-compat-0.9.1...
Installed base-compat-0.9.1
Configuring bytestring-builder-0.10.8.1.0...
Building bytestring-builder-0.10.8.1.0...
Installed bytestring-builder-0.10.8.1.0
Configuring call-stack-0.1.0...
Building call-stack-0.1.0...
Configuring clock-0.7.2...
Installed call-stack-0.1.0
Configuring data-default-class-0.1.2.0...
Installed SHA-1.6.4.2
Building clock-0.7.2...
Building data-default-class-0.1.2.0...
Configuring entropy-0.3.7...
Installed clock-0.7.2
Configuring dlist-0.8.0.2...
Installed data-default-class-0.1.2.0
Building dlist-0.8.0.2...
Configuring integer-logarithms-1...
Installed dlist-0.8.0.2
Building entropy-0.3.7...
Building integer-logarithms-1...
Configuring mtl-2.2.1...
Installed entropy-0.3.7
Configuring old-locale-1.0.0.7...
Installed integer-logarithms-1
Building mtl-2.2.1...
Building old-locale-1.0.0.7...
Configuring primitive-0.6.1.0...
Installed old-locale-1.0.0.7
Building primitive-0.6.1.0...
Configuring network-2.6.3.1...
Installed mtl-2.2.1
Configuring random-1.1...
Installed primitive-0.6.1.0
Building network-2.6.3.1...
Building random-1.1...
Configuring safe-0.3.11...
Installed random-1.1
Building safe-0.3.11...
Configuring stm-2.4.4.1...
Installed safe-0.3.11
Building stm-2.4.4.1...
Configuring time-locale-compat-0.1.1.3...
Installed network-2.6.3.1
Building time-locale-compat-0.1.1.3...
Configuring transformers-compat-0.5.1.4...
Installed stm-2.4.4.1
Configuring text-1.2.2.1...
Installed time-locale-compat-0.1.1.3
Building transformers-compat-0.5.1.4...
Building text-1.2.2.1...
Configuring unix-compat-0.4.3.1...
Installed transformers-compat-0.5.1.4
Building unix-compat-0.4.3.1...
Configuring zlib-0.6.1.2...
Installed unix-compat-0.4.3.1
Building zlib-0.6.1.2...
Installed zlib-0.6.1.2
Configuring HUnit-1.5.0.0...
Building HUnit-1.5.0.0...
Configuring data-default-instances-containers-0.0.1...
Installed HUnit-1.5.0.0
Building data-default-instances-containers-0.0.1...
Configuring data-default-instances-dlist-0.0.1...
Installed data-default-instances-containers-0.0.1
Building data-default-instances-dlist-0.0.1...
Configuring regex-base-0.93.2...
Installed text-1.2.2.1
Configuring data-default-instances-old-locale-0.0.1...
Installed data-default-instances-dlist-0.0.1
Building regex-base-0.93.2...
Building data-default-instances-old-locale-0.0.1...
Configuring async-2.1.1...
Installed data-default-instances-old-locale-0.0.1
Building async-2.1.1...
Configuring tagged-0.8.5...
Installed regex-base-0.93.2
Building tagged-0.8.5...
Configuring transformers-base-0.4.4...
Installed async-2.1.1
Building transformers-base-0.4.4...
Configuring vector-0.11.0.0...
Installed transformers-base-0.4.4
Configuring zlib-bindings-0.1.1.5...
Installed tagged-0.8.5
Building vector-0.11.0.0...
Building zlib-bindings-0.1.1.5...
Installed zlib-bindings-0.1.1.5
Configuring hashable-1.2.5.0...
Building hashable-1.2.5.0...
Configuring blaze-builder-0.4.0.2...
Installed hashable-1.2.5.0
Building blaze-builder-0.4.0.2...
Configuring readable-0.3.1...
Installed blaze-builder-0.4.0.2
Building readable-0.3.1...
Configuring data-default-0.7.1.1...
Installed readable-0.3.1
Building data-default-0.7.1.1...
Configuring parsec-3.1.11...
Installed data-default-0.7.1.1
Building parsec-3.1.11...
Configuring regex-posix-0.95.2...
Installed parsec-3.1.11
Building regex-posix-0.95.2...
Configuring monad-control-1.0.1.0...
Installed vector-0.11.0.0
Building monad-control-1.0.1.0...
Installed regex-posix-0.95.2
Configuring case-insensitive-1.2.0.7...
Building case-insensitive-1.2.0.7...
Configuring network-uri-2.6.1.0...
Installed monad-control-1.0.1.0
Building network-uri-2.6.1.0...
Configuring scientific-0.3.4.10...
Installed case-insensitive-1.2.0.7
Building scientific-0.3.4.10...
Configuring unordered-containers-0.2.7.2...
Installed network-uri-2.6.1.0
Building unordered-containers-0.2.7.2...
Installed scientific-0.3.4.10
Configuring lifted-base-0.2.3.8...
Building lifted-base-0.2.3.8...
Configuring attoparsec-0.13.1.0...
Installed lifted-base-0.2.3.8
Building attoparsec-0.13.1.0...
Installed unordered-containers-0.2.7.2
Configuring vault-0.3.0.6...
Building vault-0.3.0.6...
Installed vault-0.3.0.6
Installed attoparsec-0.13.1.0
Configuring io-streams-1.3.6.0...
Configuring websockets-0.9.8.2...
Building websockets-0.9.8.2...
Building io-streams-1.3.6.0...
Configuring aeson-1.0.2.1...
Installed websockets-0.9.8.2
Building aeson-1.0.2.1...
Installed io-streams-1.3.6.0
Configuring io-streams-haproxy-1.0.0.1...
Building io-streams-haproxy-1.0.0.1...
Installed io-streams-haproxy-1.0.0.1
Configuring snap-core-1.0.1.0...
Building snap-core-1.0.1.0...
Installed snap-core-1.0.1.0
Configuring snap-server-1.0.1.1...
Building snap-server-1.0.1.1...
Installed aeson-1.0.2.1
Installed snap-server-1.0.1.1
Configuring websockets-snap-0.10.2.0...
Building websockets-snap-0.10.2.0...
Installed websockets-snap-0.10.2.0
Configuring threepenny-gui-0.7.0.0...
Building threepenny-gui-0.7.0.0...
Installed threepenny-gui-0.7.0.0
Configuring threepenny-gui-contextmenu-0.1.0.0...
Building threepenny-gui-contextmenu-0.1.0.0...
Failed to install threepenny-gui-contextmenu-0.1.0.0
Build log ( /home/builder/.cabal/logs/threepenny-gui-contextmenu-0.1.0.0.log ):
cabal: Entering directory '/tmp/cabal-tmp-22321/threepenny-gui-contextmenu-0.1.0.0'
Configuring threepenny-gui-contextmenu-0.1.0.0...
Building threepenny-gui-contextmenu-0.1.0.0...
Preprocessing library threepenny-gui-contextmenu-0.1.0.0...
[1 of 3] Compiling ContextMenu.Util ( src/ContextMenu/Util.hs, dist/build/ContextMenu/Util.o )
[2 of 3] Compiling ContextMenu.Style ( src/ContextMenu/Style.hs, dist/build/ContextMenu/Style.o )
[3 of 3] Compiling ContextMenu      ( src/ContextMenu.hs, dist/build/ContextMenu.o )

src/ContextMenu.hs:44:8: error:
    Not in scope: ‘UI.contextmenu’
    Module ‘Graphics.UI.Threepenny’ does not export ‘contextmenu’.

src/ContextMenu.hs:89:38: error:
    Not in scope: ‘UI.position’
    Perhaps you meant ‘UI.option’ (imported from Graphics.UI.Threepenny)
    Module ‘Graphics.UI.Threepenny’ does not export ‘position’.

src/ContextMenu.hs:90:40: error:
    Not in scope: ‘UI.position’
    Perhaps you meant ‘UI.option’ (imported from Graphics.UI.Threepenny)
    Module ‘Graphics.UI.Threepenny’ does not export ‘position’.

src/ContextMenu.hs:90:69: error:
    Not in scope: ‘UI.right’
    Perhaps you meant ‘UI.height’ (imported from Graphics.UI.Threepenny)
    Module ‘Graphics.UI.Threepenny’ does not export ‘right’.

src/ContextMenu.hs:90:90: error:
    Not in scope: ‘UI.top’
    Perhaps you meant one of these:
      ‘UI.stop’ (imported from Graphics.UI.Threepenny),
      ‘UI.map’ (imported from Graphics.UI.Threepenny),
      ‘UI.on’ (imported from Graphics.UI.Threepenny)
    Module ‘Graphics.UI.Threepenny’ does not export ‘top’.
cabal: Leaving directory '/tmp/cabal-tmp-22321/threepenny-gui-contextmenu-0.1.0.0'
cabal: Error: some packages failed to install:
threepenny-gui-contextmenu-0.1.0.0 failed during the building phase. The
exception was:
ExitFailure 1