Build #3 for txt-0.0.3.0

[all reports]

Package txt-0.0.3.0
Install BuildFailed
Docs NotTried
Tests NotTried
Time submitted 2019-03-16 00:30:38.022207153 UTC
Compiler ghc-8.6.3
OS linux
Arch x86_64
Dependencies base-4.12.0.0, bytestring-0.10.8.2, deepseq-1.4.4.0, utf8-string-1.0.1.1, util-0.1.12.0
Flags none

Build log

[view raw]

Warning: The install command is a part of the legacy v1 style of cabal usage.

Please switch to using either the new project style and the new-install
command or the legacy v1-install alias as new-style projects will become the
default in the next version of cabal-install. Please file a bug if you cannot
replicate a working v1- use case with the new-style commands.

For more information, see: https://wiki.haskell.org/Cabal/NewBuild

Resolving dependencies...
Starting     util-0.1.12.0
Starting     utf8-string-1.0.1.1
Building     utf8-string-1.0.1.1
Building     util-0.1.12.0
Completed    util-0.1.12.0
Completed    utf8-string-1.0.1.1
Starting     txt-0.0.3.0
Building     txt-0.0.3.0
Failed to install txt-0.0.3.0
Build log ( /home/builder/.cabal/logs/ghc-8.6.3/txt-0.0.3.0-IKDCR4DhH9F394esD3CW55.log ):
cabal: Entering directory '/tmp/cabal-tmp-24723/txt-0.0.3.0'
Configuring txt-0.0.3.0...
Preprocessing library for txt-0.0.3.0..
Building library for txt-0.0.3.0..
[1 of 6] Compiling Data.Text.Lazy.Private ( Data/Text/Lazy/Private.hs, dist/build/Data/Text/Lazy/Private.o )
[2 of 6] Compiling Data.Text.Private ( Data/Text/Private.hs, dist/build/Data/Text/Private.o )
[3 of 6] Compiling Data.Text.Lazy   ( Data/Text/Lazy.hs, dist/build/Data/Text/Lazy.o )

Data/Text/Lazy.hs:45:41: error:
    Not in scope: ‘B.findIndexEnd’
    Perhaps you meant one of these:
      ‘B.findIndex’ (imported from Data.ByteString.Lazy),
      ‘B.elemIndexEnd’ (imported from Data.ByteString.Lazy)
    Module ‘Data.ByteString.Lazy’ does not export ‘findIndexEnd’.
   |
45 | unsnoc (Text xs) = [(Text xs, x) | k <- B.findIndexEnd isStartByte xs
   |                                         ^^^^^^^^^^^^^^
cabal: Leaving directory '/tmp/cabal-tmp-24723/txt-0.0.3.0'
cabal: Error: some packages failed to install:
txt-0.0.3.0-IKDCR4DhH9F394esD3CW55 failed during the building phase. The
exception was:
ExitFailure 1