Build #1 for v4l2-examples-0.1.0.2

[all reports]

Package v4l2-examples-0.1.0.2
Install DependencyFailed bindings-libv4l2-0.1
Docs NotTried
Tests NotTried
Time submitted unknown
Compiler ghc-7.6.3
OS linux
Arch x86_64
Dependencies v4l2-0.1.0.3, base-4.6.0.1, GLUT-2.3.1.0
Flags none

Code Coverage

No Code Coverage was submitted for this report.

Build log

[view raw]

Resolving dependencies...
Configuring ObjectName-1.0.0.0...
Building ObjectName-1.0.0.0...
Preprocessing library ObjectName-1.0.0.0...
[1 of 1] Compiling Data.ObjectName  ( src/Data/ObjectName.hs, dist/build/Data/ObjectName.o )
In-place registering ObjectName-1.0.0.0...
Running Haddock for ObjectName-1.0.0.0...
Running hscolour for ObjectName-1.0.0.0...
Preprocessing library ObjectName-1.0.0.0...
Preprocessing library ObjectName-1.0.0.0...
Warning: The documentation for the following packages are not installed. No
links will be generated to these packages: rts-1.0
Haddock coverage:
 100% (  2 /  2) in 'Data.ObjectName'
Documentation created: dist/doc/html/ObjectName/index.html
Installing library in
/srv/hackage/var/build/tmp-install/lib/ObjectName-1.0.0.0/ghc-7.6.3
Registering ObjectName-1.0.0.0...
Installed ObjectName-1.0.0.0
Configuring OpenGLRaw-1.3.0.0...
cabal: Missing dependency on a foreign library:
* Missing C library: GL
This problem can usually be solved by installing the system package that
provides this library (you may need the "-dev" version). If the library is
already installed but in a non-standard location then you can use the flags
--extra-include-dirs= and --extra-lib-dirs= to specify where it is.
Failed to install OpenGLRaw-1.3.0.0
Configuring StateVar-1.0.0.0...
Building StateVar-1.0.0.0...
Preprocessing library StateVar-1.0.0.0...
[1 of 1] Compiling Data.StateVar    ( src/Data/StateVar.hs, dist/build/Data/StateVar.o )
In-place registering StateVar-1.0.0.0...
Running Haddock for StateVar-1.0.0.0...
Running hscolour for StateVar-1.0.0.0...
Preprocessing library StateVar-1.0.0.0...
Preprocessing library StateVar-1.0.0.0...
Warning: The documentation for the following packages are not installed. No
links will be generated to these packages: rts-1.0
Haddock coverage:
 100% ( 16 / 16) in 'Data.StateVar'
Documentation created: dist/doc/html/StateVar/index.html
Installing library in
/srv/hackage/var/build/tmp-install/lib/StateVar-1.0.0.0/ghc-7.6.3
Registering StateVar-1.0.0.0...
Installed StateVar-1.0.0.0
Configuring Tensor-1.0.0.1...
Building Tensor-1.0.0.1...
Preprocessing library Tensor-1.0.0.1...
[1 of 1] Compiling Data.Tensor      ( src/Data/Tensor.hs, dist/build/Data/Tensor.o )

src/Data/Tensor.hs:57:28: Warning:
    In the use of `mkTyCon' (imported from Data.Typeable):
    Deprecated: "either derive Typeable, or use mkTyCon3 instead"

src/Data/Tensor.hs:94:28: Warning:
    In the use of `mkTyCon' (imported from Data.Typeable):
    Deprecated: "either derive Typeable, or use mkTyCon3 instead"

src/Data/Tensor.hs:131:28: Warning:
    In the use of `mkTyCon' (imported from Data.Typeable):
    Deprecated: "either derive Typeable, or use mkTyCon3 instead"

src/Data/Tensor.hs:168:28: Warning:
    In the use of `mkTyCon' (imported from Data.Typeable):
    Deprecated: "either derive Typeable, or use mkTyCon3 instead"

src/Data/Tensor.hs:205:28: Warning:
    In the use of `mkTyCon' (imported from Data.Typeable):
    Deprecated: "either derive Typeable, or use mkTyCon3 instead"

src/Data/Tensor.hs:242:28: Warning:
    In the use of `mkTyCon' (imported from Data.Typeable):
    Deprecated: "either derive Typeable, or use mkTyCon3 instead"

src/Data/Tensor.hs:279:28: Warning:
    In the use of `mkTyCon' (imported from Data.Typeable):
    Deprecated: "either derive Typeable, or use mkTyCon3 instead"

src/Data/Tensor.hs:316:28: Warning:
    In the use of `mkTyCon' (imported from Data.Typeable):
    Deprecated: "either derive Typeable, or use mkTyCon3 instead"
In-place registering Tensor-1.0.0.1...
Running Haddock for Tensor-1.0.0.1...
Running hscolour for Tensor-1.0.0.1...
Preprocessing library Tensor-1.0.0.1...
Preprocessing library Tensor-1.0.0.1...
Warning: The documentation for the following packages are not installed. No
links will be generated to these packages: rts-1.0

dist/build/tmp-16021/src/Data/Tensor.hs:57:28: Warning:
    In the use of `mkTyCon' (imported from Data.Typeable):
    Deprecated: "either derive Typeable, or use mkTyCon3 instead"

dist/build/tmp-16021/src/Data/Tensor.hs:94:28: Warning:
    In the use of `mkTyCon' (imported from Data.Typeable):
    Deprecated: "either derive Typeable, or use mkTyCon3 instead"

dist/build/tmp-16021/src/Data/Tensor.hs:131:28: Warning:
    In the use of `mkTyCon' (imported from Data.Typeable):
    Deprecated: "either derive Typeable, or use mkTyCon3 instead"

dist/build/tmp-16021/src/Data/Tensor.hs:168:28: Warning:
    In the use of `mkTyCon' (imported from Data.Typeable):
    Deprecated: "either derive Typeable, or use mkTyCon3 instead"

dist/build/tmp-16021/src/Data/Tensor.hs:205:28: Warning:
    In the use of `mkTyCon' (imported from Data.Typeable):
    Deprecated: "either derive Typeable, or use mkTyCon3 instead"

dist/build/tmp-16021/src/Data/Tensor.hs:242:28: Warning:
    In the use of `mkTyCon' (imported from Data.Typeable):
    Deprecated: "either derive Typeable, or use mkTyCon3 instead"

dist/build/tmp-16021/src/Data/Tensor.hs:279:28: Warning:
    In the use of `mkTyCon' (imported from Data.Typeable):
    Deprecated: "either derive Typeable, or use mkTyCon3 instead"

dist/build/tmp-16021/src/Data/Tensor.hs:316:28: Warning:
    In the use of `mkTyCon' (imported from Data.Typeable):
    Deprecated: "either derive Typeable, or use mkTyCon3 instead"
Haddock coverage:
 100% (  9 /  9) in 'Data.Tensor'
Documentation created: dist/doc/html/Tensor/index.html
Installing library in
/srv/hackage/var/build/tmp-install/lib/Tensor-1.0.0.1/ghc-7.6.3
Registering Tensor-1.0.0.1...
Installed Tensor-1.0.0.1
Configuring bindings-DSL-1.0.20...
Building bindings-DSL-1.0.20...
Preprocessing library bindings-DSL-1.0.20...
[1 of 1] Compiling Bindings.Utilities ( Bindings/Utilities.hs, dist/build/Bindings/Utilities.o )
In-place registering bindings-DSL-1.0.20...
Running Haddock for bindings-DSL-1.0.20...
Running hscolour for bindings-DSL-1.0.20...
Preprocessing library bindings-DSL-1.0.20...
Preprocessing library bindings-DSL-1.0.20...
Warning: The documentation for the following packages are not installed. No
links will be generated to these packages: rts-1.0
Haddock coverage:
  67% (  2 /  3) in 'Bindings.Utilities'
Documentation created: dist/doc/html/bindings-DSL/index.html
Installing library in
/srv/hackage/var/build/tmp-install/lib/bindings-DSL-1.0.20/ghc-7.6.3
Registering bindings-DSL-1.0.20...
Installed bindings-DSL-1.0.20
Configuring ioctl-0.0.1...
Building ioctl-0.0.1...
Preprocessing library ioctl-0.0.1...
[1 of 3] Compiling System.IOControl ( src/System/IOControl.hs, dist/build/System/IOControl.o )
[2 of 3] Compiling Network.Socket.IOCtl ( src-unix/Network/Socket/IOCtl.hs, dist/build/Network/Socket/IOCtl.o )
[3 of 3] Compiling System.Posix.IOCtl ( src-unix/System/Posix/IOCtl.hs, dist/build/System/Posix/IOCtl.o )
In-place registering ioctl-0.0.1...
Running Haddock for ioctl-0.0.1...
Running hscolour for ioctl-0.0.1...
Preprocessing library ioctl-0.0.1...
Preprocessing library ioctl-0.0.1...
Warning: The documentation for the following packages are not installed. No
links will be generated to these packages: rts-1.0, mtl-2.1.2,
network-2.4.1.2, parsec-3.1.3, text-0.11.2.3, transformers-0.3.0.0
Haddock coverage:
 100% (  2 /  2) in 'System.IOControl'
 100% (  5 /  5) in 'Network.Socket.IOCtl'
 100% (  5 /  5) in 'System.Posix.IOCtl'
Warning: Network.Socket.IOCtl: could not find link destinations for:
    Network.Socket.Types.Socket
Documentation created: dist/doc/html/ioctl/index.html
Installing library in
/srv/hackage/var/build/tmp-install/lib/ioctl-0.0.1/ghc-7.6.3
Registering ioctl-0.0.1...
Installed ioctl-0.0.1
Configuring bindings-libv4l2-0.1...
cabal: Missing dependency on a foreign library:
* Missing C library: v4l2
This problem can usually be solved by installing the system package that
provides this library (you may need the "-dev" version). If the library is
already installed but in a non-standard location then you can use the flags
--extra-include-dirs= and --extra-lib-dirs= to specify where it is.
Failed to install bindings-libv4l2-0.1
Configuring bindings-posix-1.2.6...
Building bindings-posix-1.2.6...
Preprocessing library bindings-posix-1.2.6...
[ 1 of 13] Compiling Bindings.Posix.Sys.Utsname ( dist/build/Bindings/Posix/Sys/Utsname.hs, dist/build/Bindings/Posix/Sys/Utsname.o )
[ 2 of 13] Compiling Bindings.Posix.Sys.Types ( dist/build/Bindings/Posix/Sys/Types.hs, dist/build/Bindings/Posix/Sys/Types.o )
[ 3 of 13] Compiling Bindings.Posix.Sys.Mman ( dist/build/Bindings/Posix/Sys/Mman.hs, dist/build/Bindings/Posix/Sys/Mman.o )
[ 4 of 13] Compiling Bindings.Posix.Unistd ( dist/build/Bindings/Posix/Unistd.hs, dist/build/Bindings/Posix/Unistd.o )
[ 5 of 13] Compiling Bindings.Posix.Signal ( dist/build/Bindings/Posix/Signal.hs, dist/build/Bindings/Posix/Signal.o )
[ 6 of 13] Compiling Bindings.Posix.Regex ( dist/build/Bindings/Posix/Regex.hs, dist/build/Bindings/Posix/Regex.o )
[ 7 of 13] Compiling Bindings.Posix.Locale ( dist/build/Bindings/Posix/Locale.hs, dist/build/Bindings/Posix/Locale.o )
[ 8 of 13] Compiling Bindings.Posix.Time ( dist/build/Bindings/Posix/Time.hs, dist/build/Bindings/Posix/Time.o )
[ 9 of 13] Compiling Bindings.Posix.Sys.Select ( dist/build/Bindings/Posix/Sys/Select.hs, dist/build/Bindings/Posix/Sys/Select.o )
[10 of 13] Compiling Bindings.Posix.Sys ( src/Bindings/Posix/Sys.hs, dist/build/Bindings/Posix/Sys.o )
[11 of 13] Compiling Bindings.Posix.Fcntl ( dist/build/Bindings/Posix/Fcntl.hs, dist/build/Bindings/Posix/Fcntl.o )
[12 of 13] Compiling Bindings.Posix.Errno ( dist/build/Bindings/Posix/Errno.hs, dist/build/Bindings/Posix/Errno.o )
[13 of 13] Compiling Bindings.Posix   ( src/Bindings/Posix.hs, dist/build/Bindings/Posix.o )
In-place registering bindings-posix-1.2.6...
Running Haddock for bindings-posix-1.2.6...
Running hscolour for bindings-posix-1.2.6...
Preprocessing library bindings-posix-1.2.6...
Preprocessing library bindings-posix-1.2.6...
Warning: The documentation for the following packages are not installed. No
links will be generated to these packages: rts-1.0
Haddock coverage:
  11% (  1 /  9) in 'Bindings.Posix.Sys.Utsname'
   3% (  1 / 31) in 'Bindings.Posix.Sys.Types'
   7% (  1 / 15) in 'Bindings.Posix.Sys.Mman'
   0% (  1 /304) in 'Bindings.Posix.Unistd'
   1% (  1 /131) in 'Bindings.Posix.Signal'
   3% (  1 / 34) in 'Bindings.Posix.Regex'
  50% (  1 /  2) in 'Bindings.Posix.Locale'
   2% (  1 / 66) in 'Bindings.Posix.Time'
   7% (  1 / 14) in 'Bindings.Posix.Sys.Select'
  80% (  4 /  5) in 'Bindings.Posix.Sys'
   3% (  1 / 34) in 'Bindings.Posix.Fcntl'
   1% (  1 / 78) in 'Bindings.Posix.Errno'
  89% (  8 /  9) in 'Bindings.Posix'
Documentation created: dist/doc/html/bindings-posix/index.html
Installing library in
/srv/hackage/var/build/tmp-install/lib/bindings-posix-1.2.6/ghc-7.6.3
Registering bindings-posix-1.2.6...
Installed bindings-posix-1.2.6
Configuring bindings-linux-videodev2-0.1...
Building bindings-linux-videodev2-0.1...
Preprocessing library bindings-linux-videodev2-0.1...
[1 of 1] Compiling Bindings.Linux.VideoDev2 ( dist/build/Bindings/Linux/VideoDev2.hs, dist/build/Bindings/Linux/VideoDev2.o )
In-place registering bindings-linux-videodev2-0.1...
Running Haddock for bindings-linux-videodev2-0.1...
Running hscolour for bindings-linux-videodev2-0.1...
Preprocessing library bindings-linux-videodev2-0.1...
Preprocessing library bindings-linux-videodev2-0.1...
Warning: The documentation for the following packages are not installed. No
links will be generated to these packages: rts-1.0, mtl-2.1.2,
network-2.4.1.2, parsec-3.1.3, text-0.11.2.3, transformers-0.3.0.0
Haddock coverage:
   0% (  1 /1110) in 'Bindings.Linux.VideoDev2'
Documentation created: dist/doc/html/bindings-linux-videodev2/index.html
Installing library in
/srv/hackage/var/build/tmp-install/lib/bindings-linux-videodev2-0.1/ghc-7.6.3
Registering bindings-linux-videodev2-0.1...
Installed bindings-linux-videodev2-0.1
cabal: Error: some packages failed to install:
GLURaw-1.4.0.0 depends on OpenGLRaw-1.3.0.0 which failed to install.
GLUT-2.3.1.0 depends on OpenGLRaw-1.3.0.0 which failed to install.
OpenGL-2.6.0.1 depends on OpenGLRaw-1.3.0.0 which failed to install.
OpenGLRaw-1.3.0.0 failed during the configure step. The exception was:
ExitFailure 1
bindings-libv4l2-0.1 failed during the configure step. The exception was:
ExitFailure 1
v4l2-0.1.0.3 depends on bindings-libv4l2-0.1 which failed to install.
v4l2-examples-0.1.0.2 depends on bindings-libv4l2-0.1 which failed to install.