The vty-ui package

[Tags: bsd3, deprecated, library]

Deprecated in favor of brick

An extensible library of user interface widgets for composing and laying out Vty user interfaces. This library provides a collection of primitives for building and composing widgets and creating Vty Images. This library is intended to make non-trivial user interfaces trivial to express and modify without having to worry about terminal size.

Properties

Versions0.1, 0.2, 0.3, 0.4, 1.0, 1.0.1, 1.1, 1.2, 1.3, 1.3.1, 1.4, 1.5, 1.5.1, 1.6, 1.6.1, 1.7, 1.7.1, 1.8, 1.9
Change logNone available
Dependenciesbase (==4.*), containers (>=0.2 && <0.4), mtl (==1.1.*), pcre-light (==0.3.*), QuickCheck (==2.1.*), vty (>=4.0 && <4.5) [details]
LicenseBSD3
AuthorJonathan Daugherty <drcygnus@gmail.com>
MaintainerJonathan Daugherty <drcygnus@gmail.com>
CategoryUser Interfaces
Home pagehttp://codevine.org/vty-ui/
Executablesvty-ui-demo, vty-ui-tests
UploadedWed Sep 8 02:30:15 UTC 2010 by JonathanDaugherty
DistributionsNixOS:1.9
Downloads3559 total (128 in last 30 days)
Votes
0 []
StatusDocs uploaded by user
Build status unknown [no reports yet]

Modules

[Index]

Flags

NameDescriptionDefaultType
testingBuild for testingDisabledAutomatic

Use -f <flag> to enable a flag, or -f -<flag> to disable that flag. More info

Downloads

Maintainers' corner

For package maintainers and hackage trustees