Build #1 for wigner-ville-accelerate-0.1.0.1

[all reports]

Package wigner-ville-accelerate-0.1.0.1
Install DependencyFailed cuda-0.8.0.1
Docs NotTried
Tests NotTried
Time submitted 2017-10-24 15:51:52.866228147 UTC
Compiler ghc-8.0.2
OS linux
Arch x86_64
Dependencies accelerate-1.1.1.0, accelerate-fft-1.1.0.0, base-4.9.1.0
Flags none

Code Coverage

No Code Coverage was submitted for this report.

Build log

[view raw]

Resolving dependencies...
Configuring base-orphans-0.6...
Configuring Cabal-2.0.0.2...
Building base-orphans-0.6...
Building Cabal-2.0.0.2...
Configuring cereal-0.5.4.0...
Installed base-orphans-0.6
Building cereal-0.5.4.0...
Configuring data-default-class-0.1.2.0...
Installed cereal-0.5.4.0
Building data-default-class-0.1.2.0...
Configuring dlist-0.8.0.3...
Installed data-default-class-0.1.2.0
Building dlist-0.8.0.3...
Configuring colour-2.3.3...
Installed dlist-0.8.0.3
Building colour-2.3.3...
Configuring integer-logarithms-1.0.2...
Installed colour-2.3.3
Building integer-logarithms-1.0.2...
Configuring file-embed-0.0.10.1...
Installed integer-logarithms-1.0.2
Building file-embed-0.0.10.1...
Configuring ix-shapable-0.1.0...
Installed file-embed-0.0.10.1
Building ix-shapable-0.1.0...
Configuring mtl-2.2.1...
Installed ix-shapable-0.1.0
Building mtl-2.2.1...
Configuring libffi-0.1...
Installed mtl-2.2.1
Building libffi-0.1...
Configuring primitive-0.6.2.0...
Installed libffi-0.1
Building primitive-0.6.2.0...
Configuring stm-2.4.4.1...
Installed primitive-0.6.2.0
Building stm-2.4.4.1...
Configuring random-1.1...
Installed stm-2.4.4.1
Building random-1.1...
Configuring storable-complex-0.2.2...
Installed random-1.1
Building storable-complex-0.2.2...
Configuring syb-0.7...
Installed storable-complex-0.2.2
Building syb-0.7...
Configuring transformers-compat-0.5.1.4...
Installed syb-0.7
Building transformers-compat-0.5.1.4...
Configuring utf8-string-1.0.1.1...
Installed transformers-compat-0.5.1.4
Building utf8-string-1.0.1.1...
Configuring text-1.2.2.2...
Installed utf8-string-1.0.1.1
Building text-1.2.2.2...
Installed text-1.2.2.2
Configuring ansi-terminal-0.7.1.1...
Building ansi-terminal-0.7.1.1...
Configuring fclabels-2.0.3.2...
Installed ansi-terminal-0.7.1.1
Building fclabels-2.0.3.2...
Installed fclabels-2.0.3.2
Configuring atomic-primops-0.8.1...
Building atomic-primops-0.8.1...
Configuring abstract-deque-0.3...
Installed atomic-primops-0.8.1
Building abstract-deque-0.3...
Configuring vector-0.12.0.1...
Installed abstract-deque-0.3
Building vector-0.12.0.1...
Configuring exceptions-0.8.3...
Installed Cabal-2.0.0.2
Downloading cuda-0.8.0.1...
Building exceptions-0.8.3...
Configuring tf-random-0.5...
Installed exceptions-0.8.3
Building tf-random-0.5...
Installed tf-random-0.5
Configuring hashable-1.2.6.1...
Building hashable-1.2.6.1...
Installed vector-0.12.0.1
Configuring ansi-wl-pprint-0.6.8.1...
Installed hashable-1.2.6.1
Configuring cuda-0.8.0.1...
Building ansi-wl-pprint-0.6.8.1...
Configuring QuickCheck-2.10.1...
Failed to install cuda-0.8.0.1
Build log ( /home/builder/.cabal/logs/cuda-0.8.0.1.log ):
cabal: Entering directory '/tmp/cabal-tmp-1178/cuda-0.8.0.1'
[1 of 1] Compiling Main             ( /tmp/cabal-tmp-1178/cuda-0.8.0.1/dist/setup/setup.hs, /tmp/cabal-tmp-1178/cuda-0.8.0.1/dist/setup/Main.o )
Linking /tmp/cabal-tmp-1178/cuda-0.8.0.1/dist/setup/setup ...
Configuring cuda-0.8.0.1...
setup:
********************************************************************************

The configuration process failed to locate your CUDA installation. Ensure that
you have installed both the developer driver and toolkit, available from:

> http://developer.nvidia.com/cuda-downloads

and make sure that `nvcc` is available in your PATH, or set the CUDA_PATH
environment variable appropriately. Check the above output log and run the
command directly to ensure it can be located.

If you have a non-standard installation, you can add additional search paths
using --extra-include-dirs and --extra-lib-dirs. Note that 64-bit Linux
flavours often require both `lib64` and `lib` library paths, in that order.

********************************************************************************
cabal: Leaving directory '/tmp/cabal-tmp-1178/cuda-0.8.0.1'
Installed ansi-wl-pprint-0.6.8.1
Configuring vector-th-unbox-0.2.1.6...
Building QuickCheck-2.10.1...
Building vector-th-unbox-0.2.1.6...
Configuring chaselev-deque-0.5.0.5...
Installed vector-th-unbox-0.2.1.6
Building chaselev-deque-0.5.0.5...
Configuring scientific-0.3.5.2...
Installed chaselev-deque-0.5.0.5
Building scientific-0.3.5.2...
Configuring hashtables-1.2.2.1...
Installed scientific-0.3.5.2
Building hashtables-1.2.2.1...
Configuring unique-0...
Installed hashtables-1.2.2.1
Configuring unordered-containers-0.2.8.0...
Installed QuickCheck-2.10.1
Building unique-0...
Building unordered-containers-0.2.8.0...
Installed unique-0
Configuring math-functions-0.2.1.0...
Building math-functions-0.2.1.0...
Configuring carray-0.1.6.8...
Installed unordered-containers-0.2.8.0
Building carray-0.1.6.8...
Configuring attoparsec-0.13.2.0...
Installed carray-0.1.6.8
Building attoparsec-0.13.2.0...
Installed math-functions-0.2.1.0
Configuring fft-0.1.8.6...
Building fft-0.1.8.6...
Configuring accelerate-1.1.1.0...
Installed fft-0.1.8.6
Building accelerate-1.1.1.0...
Configuring mwc-random-0.13.6.0...
Installed attoparsec-0.13.2.0
Building mwc-random-0.13.6.0...
Installed mwc-random-0.13.6.0
Configuring llvm-hs-pure-5.1.0...
Building llvm-hs-pure-5.1.0...
Installed llvm-hs-pure-5.1.0
Configuring llvm-hs-5.1.0...
Failed to install llvm-hs-5.1.0
Build log ( /home/builder/.cabal/logs/llvm-hs-5.1.0.log ):
cabal: Entering directory '/tmp/cabal-tmp-1178/llvm-hs-5.1.0'
[1 of 1] Compiling Main             ( /tmp/cabal-tmp-1178/llvm-hs-5.1.0/dist/setup/setup.hs, /tmp/cabal-tmp-1178/llvm-hs-5.1.0/dist/setup/Main.o )
Linking /tmp/cabal-tmp-1178/llvm-hs-5.1.0/dist/setup/setup ...
setup: The program 'llvm-config' version ==5.0.* is required but the version
found at /usr/bin/llvm-config is version 3.4
cabal: Leaving directory '/tmp/cabal-tmp-1178/llvm-hs-5.1.0'
Installed accelerate-1.1.1.0
cabal: Error: some packages failed to install:
accelerate-fft-1.1.0.0 depends on cuda-0.8.0.1 which failed to install.
accelerate-llvm-1.1.0.0 depends on llvm-hs-5.1.0 which failed to install.
accelerate-llvm-native-1.1.0.1 depends on llvm-hs-5.1.0 which failed to
install.
accelerate-llvm-ptx-1.1.0.0 depends on cuda-0.8.0.1 which failed to install.
cuda-0.8.0.1 failed during the configure step. The exception was:
ExitFailure 1
cufft-0.8.0.0 depends on cuda-0.8.0.1 which failed to install.
llvm-hs-5.1.0 failed during the configure step. The exception was:
ExitFailure 1
nvvm-0.8.0.0 depends on cuda-0.8.0.1 which failed to install.
wigner-ville-accelerate-0.1.0.1 depends on cuda-0.8.0.1 which failed to
install.