The LambdaHack package

[Tags: bsd3, library, program]

a small roguelike game


[Skip to ReadMe]

Properties

Versions0.1.20080412, 0.1.20080413, 0.1.20090606, 0.1.20110117, 0.1.20110918, 0.2.0, 0.2.1, 0.2.6, 0.2.6.5, 0.2.8, 0.2.10, 0.2.10.5, 0.2.10.6, 0.2.12, 0.2.14, 0.4.9.0, 0.4.99.0, 0.4.100.0, 0.4.101.0, 0.4.101.1, 0.5.0.0
Change logNone available
Dependenciesbase (==3.*), binary (>=0.4 && <1), bytestring (>=0.9 && <1), containers (>=0.1 && <1), directory (==1.*), gtk (>=0.9.12 && <0.11), hscurses (>=1.3 && <2), mtl (>=1.1 && <2), random (==1.*), vty (>=3), zlib (>=0.4 && <1) [details]
LicenseGPL
AuthorAndres Loeh <mail@andres-loeh.de>
MaintainerAndres Loeh <mail@andres-loeh.de>
CategoryGame
ExecutablesLambdaHack
UploadedSat Jun 6 12:41:05 UTC 2009 by AndresLoeh
DistributionsNixOS:0.5.0.0
Downloads4168 total (224 in last 30 days)
Votes
0 []
StatusDocs not available [build log]
All reported builds failed as of 2015-05-22 [all 1 reports]

Flags

NameDescriptionDefaultType
cursesenable curses supportDisabledAutomatic
gtkenable gtk supportEnabledAutomatic

Use -f <flag> to enable a flag, or -f -<flag> to disable that flag. More info

Downloads

Maintainers' corner

For package maintainers and hackage trustees

Readme for LambdaHack-0.1.20090606

Installation via Cabal.

There are three displays to choose from, depending on
the flags passed to Setup configure:

  * gtk2hs  (the default)
  * vty     (Setup configure -f-gtk)
  * curses  (Setup configure -fcurses)

The curses display is the newest and least tested,
the other two should be stable.