The bindings-sc3 package

[Tags: gpl, library]

DEPRECATED. This library is looking for a new maintainer.

This library provides low level bindings to the SuperCollider synthesis engine library (libscsynth). If you are looking for a higher level Haskell interface, please use the hsc3-process package (http://hackage.haskell.org/package/hsc3-process).

ChangeLog: https://github.com/kaoskorobase/bindings-sc3/blob/master/ChangeLog.md

In order to use this package, you need to build the dynamic library version of SuperCollider supercollider.sourceforge.net by passing -DLIBSCSYNTH=ON to cmake and put it in a location where it can be found by the linker (e.g. usrlocal/lib on Unix systems, alternatively use the --extra-lib-dirs flag of cabal configure).

The required SuperCollider version is 3.5.


Properties

Versions0.0.0, 0.3.0, 0.4.1
Dependenciesbase (>=3 && <5), bindings-DSL (==1.0.*)
LicenseGPL
CopyrightCopyright (c) Stefan Kersten 2010-2012
AuthorStefan Kersten <sk@k-hornz.de>
MaintainerStefan Kersten <sk@k-hornz.de>
Stabilityexperimental
CategoryFFI, Sound
Home pagehttps://github.com/kaoskorobase/bindings-sc3/
Bug trackerhttps://github.com/kaoskorobase/bindings-sc3/issues/
Source repositoryhead: git clone git://github.com/kaoskorobase/bindings-sc3.git
Upload dateTue Nov 6 14:38:12 UTC 2012
Uploaded byStefanKersten
Downloads175 total (22 in last 30 days)

Modules

Downloads

Maintainers' corner

For package maintainers and hackage trustees