The cabal-progdeps package

[Tags: bsd3, program]

This utility can be used to display the version dependency information for the program being built in the current directory. Essentially it parses the dist/setup-config and displays the information in a readable format. This can be very helpful when adding version constraints to your package's dependencies in that it shows what your package is currently built (or configured to be built) with.

n.b. It's called progdeps instead of pkgdeps because it's examining the build information in the current directory and not actual packages.

Usage: cabal-progdeps

Works with cabal-dev and cabal.


Properties

Version1.0
Dependenciesbase (==4.*), Cabal (>1.10 && <2), directory (==1.1.*), filepath (==1.2.*)
LicenseBSD3
AuthorKevin Quick
Maintainerquick@sparq.org
CategoryDistribution
Executablescabal-progdeps
Upload dateSat Jan 14 07:23:21 UTC 2012
Uploaded byKevinQuick
Downloads130 total (12 in last 30 days)

Downloads

Maintainers' corner

For package maintainers and hackage trustees