The cabal-rpm package

[Tags: gpl, program]

This package generates RPM packages from Haskell Cabal packages.

Recent changes:

See https://github.com/juhp/cabal-rpm/blob/master/NEWS for more details.


[Skip to ReadMe]

Properties

Versions0.2, 0.2.1, 0.2.2, 0.2.3, 0.2.4, 0.2.5, 0.3.1, 0.3.2, 0.3.3, 0.4, 0.5, 0.5.1, 0.6.0, 0.6.1, 0.6.2, 0.6.3, 0.6.4, 0.6.5, 0.6.6, 0.7.0, 0.7.1, 0.8.0, 0.8.1, 0.8.2, 0.8.3, 0.8.4, 0.8.5, 0.8.6, 0.8.7, 0.8.8, 0.8.9, 0.8.10, 0.8.11, 0.9, 0.9.1, 0.9.2, 0.9.3, 0.9.4, 0.9.5, 0.9.5.1, 0.9.6
Change logNone available
Dependenciesbase (<5), Cabal (>1.10), directory, filepath, old-locale, process, regex-compat, time, unix [details]
LicenseGPL-3
Copyright2007-2008 Bryan O'Sullivan <bos@serpentine.com>, 2012-2013 Jens Petersen <petersen@fedoraproject.org>
AuthorBryan O'Sullivan <bos@serpentine.com>
MaintainerJens Petersen <juhp@community.haskell.org>
CategoryDistribution
Home pagehttps://github.com/juhp/cabal-rpm
Bug trackerhttps://github.com/juhp/cabal-rpm/issues
Source repositoryhead: git clone https://github.com/juhp/cabal-rpm
Executablescblrpm
UploadedTue Jul 2 03:23:09 UTC 2013 by JensPetersen
DistributionsFedora:0.9.4, LTSHaskell:0.9.6, NixOS:0.9.6, Stackage:0.9.6
Downloads6001 total (314 in last 30 days)
Votes
0 []
StatusDocs not available [build log]
Last success reported on 2015-05-24 [all 2 reports]

Downloads

Maintainers' corner

For package maintainers and hackage trustees

Readme for cabal-rpm-0.8.2

Build Status

cabal-rpm

cabal-rpm creates RPM spec files for packaging Haskell Cabal-based packages.

This version updates the older cabal-rpm-0.5.1 package by Bryan O'Sullivan (see README.orig) to work with current Cabal and also updated to current RPM packaging conventions defined until now by cabal2spec which is used by Fedora and also OpenSuSE. It is licensed under the terms of the GPL version 3 (see the COPYING file). It is designed to replace the simple cabal2spec tool shell script made by the maintainer.

You can build from source as normal by running cabal install or via Hackage with cabal install cabal-rpm.

Requirements

cabal-rpm assumes you are using ghc-rpm-macros for Haskell RPM packaging. It currently needs Cabal 1.10 or later to build (ie ghc7), but it should not be hard to patch it to build at least for ghc-6.12.

Usage

To create a .spec file for a Haskell src package in the current dir:

$ cblrpm spec

or directly on a .cabal file:

$ cblrpm spec path/to/mypkg.cabal

or tarball:

$ cblrpm spec path/to/mypkg-version.tar.gz

or on a package source dir:

$ cblrpm spec mypkg-0.1

You can also package directly from hackage:

$ cblrpm build somepkg

or

$ cblrpm build somepkg-0.1

will unpack the (latest) 'somepkg' package from hackage (if the dir does not exist, otherwise it uses the existing dir), create a spec file for it, and build it.

cblrpm always creates .spec files in the current dir and if a .spec file already exists it will append .cblrpm to the generated filename to avoid overwriting an existing file.

Development

The latest source code is available from: https://github.com/juhp/cabal-rpm

Plans

More features are planned and patches welcome, including recursive packaging. See the TODO file for more details.