The classy-prelude package

[Tags:library, mit]

Focuses on using common typeclasses when possible, and creating new ones to avoid name clashing. Exposes many recommended datastructures (Map, ByteString, etc) directly without requiring long import lists and qualified modules.

Properties

Versions 0.1.0.0, 0.2.0.0, 0.2.0.1, 0.3.0, 0.3.1, 0.4.0, 0.4.0.1, 0.4.1, 0.4.2, 0.4.3, 0.4.4, 0.5.0, 0.5.1, 0.5.2, 0.5.3, 0.5.4, 0.5.6, 0.5.7, 0.5.8, 0.5.9, 0.5.10, 0.6.0, 0.6.0.1, 0.7.0, 0.8.0, 0.8.0.1, 0.8.1, 0.8.1.1, 0.8.2, 0.8.3, 0.8.3.1, 0.9.0, 0.9.1, 0.9.2, 0.9.3, 0.9.4, 0.9.5, 0.10.0, 0.10.1, 0.10.2, 0.10.3, 0.10.4, 0.10.5, 0.11.0, 0.11.1, 0.11.1.1, 0.12.0, 0.12.0.1, 0.12.1, 0.12.1.1, 0.12.3, 0.12.4, 0.12.5, 0.12.5.1, 0.12.6, 0.12.7
Dependencies async (>=2.0), base (==4.*), basic-prelude (>=0.3.6 && <0.4), bytestring, containers (>=0.4.2), deepseq, hashable, lifted-base (>=0.2), monad-control, mono-traversable (<0.2), semigroups, system-filepath (==0.4.*), text, transformers, unordered-containers, vector, vector-instances [details]
License MIT
Author Michael Snoyman
Maintainer michael@snoyman.com
Stability Unknown
Category Control, Prelude
Home page https://github.com/snoyberg/classy-prelude
Source repository head: git clone git://github.com/snoyberg/classy-prelude.git
Uploaded Wed Sep 25 09:52:33 UTC 2013 by MichaelSnoyman
Updated Tue May 24 10:50:31 UTC 2016 by AdamBergmark to revision 1
Distributions Debian:0.12.5, FreeBSD:0.12.1.1, LTSHaskell:0.12.7, NixOS:0.12.7
Downloads 19718 total (136 in the last 30 days)
Votes
0 []
Status Docs available [build log]
Successful builds reported [all 1 reports]

Modules

[Index]

Downloads

Maintainer's Corner

For package maintainers and hackage trustees