comonad-extras: Comonad transformers requiring extensions to Haskell 98

[ bsd3, comonads, control, library ] [ Propose Tags ]

Comonads and comonad transformers that require extensions to Haskell 98

Versions 0.1, 0.1.1, 0.1.2, 0.1.3, 0.2, 0.2.1, 0.3.0, 0.4.0, 0.4.0.1, 0.4.0.2, 0.4.0.3, 2.0, 2.0.2, 2.0.2.1, 2.0.3, 2.1, 2.1.1, 2.1.1.1, 2.1.1.2, 2.1.2, 3.0, 3.0.0.1, 3.0.1, 3.0.2, 4.0
Dependencies array (>=0.3.0.2 && <0.4), base (==4.*), comonad (>=1.1.0.1 && <1.2), comonad-transformers (==1.8.*), comonads-fd (==1.8.*), containers (==0.4.*), distributive (==0.2.*), semigroupoids (>=1.2.2 && <1.3), semigroups (==0.5.*), transformers (>=0.2.0 && <=0.3) [details]
License BSD-3-Clause
Copyright Copyright (C) 2011 Edward A. Kmett
Author Edward A. Kmett
Maintainer Edward A. Kmett <ekmett@gmail.com>
Category Control, Comonads
Home page http://github.com/ekmett/comonad-extras/
Source repo head: git clone git://github.com/ekmett/comonad-extras.git
Uploaded by EdwardKmett at Tue Jul 26 22:07:54 UTC 2011
Distributions NixOS:4.0
Downloads 9441 total (67 in the last 30 days)
Rating (no votes yet) [estimated by rule of succession]
Your Rating
  • λ
  • λ
  • λ
Status Docs not available [build log]
All reported builds failed as of 2016-12-27 [all 8 reports]
Hackage Matrix CI

Modules

  • Control
    • Comonad
      • Store
        • Control.Comonad.Store.Pointer
        • Control.Comonad.Store.Zipper

Flags

NameDescriptionDefaultType
derivedatatypeableEnabledAutomatic

Use -f <flag> to enable a flag, or -f -<flag> to disable that flag. More info

Downloads

Maintainer's Corner

For package maintainers and hackage trustees