ghc-pkg-autofix: Simple utility to fix BROKEN package dependencies for cabal-install.

[ bsd3, development, program ] [ Propose Tags ]
Versions 0.1, 0.1.1, 0.1.2, 0.1.3, 0.1.4, 0.2.0,
Dependencies base (==4.*), Cabal (>=1.8 && <2), cmdargs (==0.9.*), filepath (==1.*), parsec (==3.*), process (==1.0.*), split (==0.1.*) [details]
License BSD-3-Clause
Author Hiromi ISHII
Category Development
Source repo head: git clone git://
Uploaded by HiromiIshii at Sat Feb 18 07:54:39 UTC 2012
Distributions NixOS:
Executables ghc-pkg-autofix
Downloads 2636 total (23 in the last 30 days)
Rating (no votes yet) [estimated by rule of succession]
Your Rating
  • λ
  • λ
  • λ
Status Docs not available [build log]
All reported builds failed as of 2016-12-25 [all 8 reports]
Hackage Matrix CI

The cabal-install sometimes reinstall existing library and break some package dependencies. This utility fixes such situations by replacing old package id in "broken" package with new id. Please Use at your own risk. NOTE for v.0.2: Now ghc-pkg-autofix supports cabal-dev!


Maintainer's Corner

For package maintainers and hackage trustees