hackage-security-HTTP: Hackage security bindings against the HTTP library

[ bsd3, distribution, library ] [ Propose Tags ]

The hackage security library provides a HttpLib abstraction to allow to bind against different HTTP libraries. This library implements this abstraction using the HTTP library.

Versions 0.1.0.0, 0.1.0.1, 0.1.0.2, 0.1.1
Change log ChangeLog.md
Dependencies base (>=4.4 && <5), bytestring (>=0.9 && <0.11), hackage-security (==0.5.*), HTTP (>=4000.2.19 && <4000.4), mtl (==2.2.*), network (>=2.5 && <2.7), network-uri (==2.6.*), zlib (>=0.5 && <0.7) [details]
License BSD-3-Clause
Copyright Copyright 2015 Well-Typed LLP
Author Edsko de Vries
Maintainer edsko@well-typed.com
Revised Revision 1 made by HerbertValerioRiedel at Mon May 9 09:05:26 UTC 2016
Category Distribution
Home page https://github.com/well-typed/hackage-security
Bug tracker https://github.com/well-typed/hackage-security/issues
Source repo head: git clone https://github.com/well-typed/hackage-security.git
Uploaded by EdskoDeVries at Wed Jan 6 15:49:36 UTC 2016
Distributions NixOS:0.1.1
Downloads 1406 total (13 in the last 30 days)
Rating (no votes yet) [estimated by rule of succession]
Your Rating
  • λ
  • λ
  • λ
Status Docs available [build log]
Last success reported on 2016-01-06 [all 1 reports]
Hackage Matrix CI

Modules

[Index]

Flags

NameDescriptionDefaultType
use-network-uri

Are we using network-uri?

EnabledAutomatic

Use -f <flag> to enable a flag, or -f -<flag> to disable that flag. More info

Downloads

Note: This package has metadata revisions in the cabal description newer than included in the tarball. To unpack the package including the revisions, use 'cabal get'.

Maintainer's Corner

For package maintainers and hackage trustees