The haskoin-crypto package

[Tags: deprecated, library, public-domain]

Deprecated in favor of haskoin

This package provides the elliptic curve cryptography required for creating and validating bitcoin transactions. It also provides SHA-256 and RIPEMD-160 hashing functions.


Properties

Versions0.0.1, 0.0.1.1
Dependenciesbase (==4.6.*), binary (==0.7.*), byteable (==0.1.*), bytestring (==0.10.*), containers (==0.5.*), cryptohash (==0.11.*), haskoin-util (==0.0.*), mtl (==2.1.*), QuickCheck (==2.6.*)
LicensePublicDomain
AuthorPhilippe Laprade
Maintainerplaprade+hackage@gmail.com
Stabilityexperimental
CategoryBitcoin, Finance, Network
Home pagehttp://github.com/plaprade/haskoin-crypto
Bug trackerhttp://github.com/plaprade/haskoin-crypto/issues
Source repositoryhead: git clone git://github.com/plaprade/haskoin-crypto.git
Upload dateSun Dec 15 16:47:23 UTC 2013
Uploaded byPhilippeLaprade
Downloads248 total (19 in last 30 days)

Modules

[Index]

Downloads

Maintainers' corner

For package maintainers and hackage trustees