The hswip package

[Tags: gpl, library]

Library for embedding swi-prolog in haskell inspired by pyswip. You should install swi-prolog in order to use the library. It is recommended to use swi-prolog-5.10 or newer. If you encounter troubles related to libswipl linking, you need to fix extra-lib-dirs parameter in hswipr.cabal to find libswipl.a in your system.


Properties

Version0.3
Dependenciesbase (<5), haskell98, mtl (>=1.1)
LicenseGPL
Copyright(c) Evgeny Tarasov
Maintaineretarasov.ekb@gmail.com
Stabilityexperimental
CategoryForeign, Language
Upload dateFri Aug 13 09:18:45 UTC 2010
Uploaded byEvgenyTarasov
Downloads105 total (14 in last 30 days)

Modules

Downloads

Maintainers' corner

For package maintainers and hackage trustees