The imperative-edsl-vhdl package

[Tags:bsd3, deprecated, library]
Deprecated. in favor of hardware-edsl

Deep embedding of VHDL programs with code generation.

Properties

Versions 0.2, 0.2.0.1, 0.3.2
Dependencies base (==4.*), bytestring, constraints, containers (>=0.1 && <1), language-vhdl (>=0.1.2.3), mtl (>=2.2 && <3), operational-alacarte (>=0.1.1), pretty (>=1.0), syntactic (>=3.2) [details]
License BSD3
Author Markus Aronsson
Maintainer mararon@chalmers.se
Stability Unknown
Category Language
Uploaded Mon Dec 14 15:38:52 UTC 2015 by mararon
Distributions NixOS:0.3.2
Downloads 170 total (6 in the last 30 days)
Votes
0 []
Status Docs not available [build log]
All reported builds failed as of 2016-11-29 [all 2 reports]

Modules

  • Language
    • Embedded
      • Language.Embedded.VHDL
        • Language.Embedded.VHDL.Command
        • Language.Embedded.VHDL.Expression
          • Language.Embedded.VHDL.Expression.Hoist
          • Language.Embedded.VHDL.Expression.Represent
        • Language.Embedded.VHDL.Interface
        • Language.Embedded.VHDL.Monad
          • Language.Embedded.VHDL.Monad.Expression
          • Language.Embedded.VHDL.Monad.Type

Downloads

Maintainer's Corner

For package maintainers and hackage trustees