The language-fortran package

[Tags:bsd3, deprecated, library]
Deprecated. in favor of fortran-src

Lexer and parser for Fortran roughly supporting standards from FORTRAN 77 to Fortran 2003 (but with some patches and rough edges). Also includes language extension support for units-of-measure typing.

Properties

Versions 0.2.7, 0.3, 0.4, 0.5, 0.5.1
Dependencies array (>=0.4), base (>=4.0 && <5), haskell-src (>=1.0), parsec, syb (>=0.3) [details]
License BSD3
Author Jason Dagit, Dominic Orchard, Oleg Oshmyan
Maintainer dagitj@gmail.com, dom.orchard@gmail.com
Stability Unknown
Category Language
Bug tracker https://github.com/dagit/language-fortran/issues
Source repository head: git clone https://github.com/dagit/language-fortran
Uploaded Thu Mar 17 18:31:16 UTC 2016 by DominicOrchard
Distributions LTSHaskell:0.5.1, NixOS:0.5.1, Stackage:0.5.1, Tumbleweed:0.5.1
Downloads 562 total (13 in the last 30 days)
Votes
0 []
Status Docs available [build log]
Last success reported on 2016-03-17 [all 1 reports]

Modules

[Index]

Downloads

Maintainer's Corner

For package maintainers and hackage trustees