The leksah package

[Tags: gpl, library, program]

An Integrated Development Environment for Haskell written in Haskell.


[Skip to ReadMe]

Properties

Versions0.1, 0.1.1, 0.4, 0.4.0.1, 0.4.0.2, 0.4.0.3, 0.4.1, 0.4.2, 0.4.2.1, 0.4.3, 0.4.4, 0.4.4.1, 0.6.0, 0.6.1, 0.8, 0.8.0.1, 0.8.0.3, 0.8.0.4, 0.8.0.6, 0.8.0.8, 0.10.0.0, 0.10.0.1, 0.10.0.3, 0.10.0.4, 0.12.0.3, 0.12.1.0, 0.12.1.2, 0.12.1.3, 0.13.3.0, 0.13.4.0, 0.13.4.1, 0.13.4.2, 0.13.4.3, 0.14.0.0, 0.14.0.1, 0.14.1.0, 0.14.1.1, 0.14.2.0, 0.14.3.0, 0.14.4.0, 0.15.0.1, 0.15.0.2, 0.15.0.3, 0.15.0.4, 0.15.0.5, 0.15.0.6, 0.15.1.0, 0.15.1.1, 0.15.1.2, 0.15.1.3, 0.15.1.4 (info)
Change logNone available
Dependenciesbase (>=2.1), binary (>=0.4.1), bytestring (>=0.9.0.1), Cabal (>=1.1.6.2), containers (>=0.1), directory (>=1.0), filepath (>=1.0), ghc (>=6.8), glib (>=0.9.12), gtk (>=0.9.12), mtl (>=1.0.1), old-time (>=1.0), parsec (>=2.0), pretty (>=1.0), process (>=1.0), sourceview (>=0.9.12) [details]
LicenseGPL
Copyright2007 Juergen Nicklisch-Franken
AuthorJutaro (Juergen Nicklisch-Franken)
MaintainerJuergen Nicklisch-Franken
Stabilityprovisional
CategoryDevelopment
Executablesleksah
UploadedSun Feb 10 15:12:10 UTC 2008 by JuergenNicklischFranken
DistributionsDebian:0.12.1.3, Fedora:0.12.1.3, NixOS:0.15.1.4
Downloads7943 total (511 in last 30 days)
Votes
0 []
StatusDocs not available [build log]
All reported builds failed as of 2015-06-03 [all 1 reports]

Downloads

Maintainers' corner

For package maintainers and hackage trustees

Readme for leksah-0.1

Leksah, an Integrated Development Environment for Haskell
=========================================================

This is Leksah, a hopefully practical tool to support the Haskell development process.

Leksah uses GTK+ as GUI Toolkit with the gtk2hs binding. It is plattform independend
and should run on any plattform where GTK+, gtk2hs and ghc can be installed.
It is currently been tested on Windows and Linux. It uses the Cabal package management
and build system for Package Management.
It currently only supports the Glasgow Haskell Compiler (ghc).

Documentation can be found in the doc/ subdirectory.

System Requirements
===================

Leksah currently requires:
    GHC version 6.8.x
    gtk >=0.9.12, glib >=0.9.12, sourceview >=0.9.12
        which are part of gtk2hs and require GTk+ to be installed
    binary >= 0.4.1

Leksah works better if you install GHC and additional packages with sources

Personal words
==============
The development of an IDE is a big issue, so Leksah is intended to become a
community project and everyone is invited to contribute.

If you are a user or just test Leksah, I would appreciate to here from you.

Please send questions and suggestions to me:
Jutaro <jnf@arcor.de>