The libnotify package

[Tags:library, mit]

The package provides a high level interface to libnotify API (see Libnotify)

Libnotify.C.Notify and Libnotify.C.NotifyNotification modules contain bindings to C-level functions if you're into that


[Skip to Readme]

Properties

Versions 0.0.1.1, 0.0.1.2, 0.0.2.0, 0.0.2.1, 0.1.0.0, 0.1.1.0, 0.2
Change log CHANGELOG.md
Dependencies base (>=4.5 && <5), bytestring (>=0.9), glib (>=0.12.3), gtk (>=0.12.3) [details]
License MIT
Author Emon Tsukimiya, Matvey Aksenov
Maintainer Matvey Aksenov <matvey.aksenov@gmail.com>
Stability Unknown
Category System, Desktop
Source repository head: git clone https://github.com/supki/libnotify
this: git clone https://github.com/supki/libnotify(tag 0.2)
Uploaded Sat Aug 13 19:22:29 UTC 2016 by MatveyAksenov
Distributions LTSHaskell:0.1.1.0, NixOS:0.2, Stackage:0.2, Tumbleweed:0.1.1.0
Downloads 1322 total (14 in the last 30 days)
Votes
0 []
Status Docs available [build log]
Last success reported on 2016-08-13 [all 1 reports]

Modules

[Index]

Downloads

Maintainer's Corner

For package maintainers and hackage trustees

Readme for libnotify

Readme for libnotify-0.2

libnotify

Hackage Build Status

Bindings to libnotify library

Note that although the bindings are distributed under MIT license everything else is GPLed. And by everything I mean everything: glib, libnotify, haskell bindings to glib, and so forth. That effectively means that by using libnotify bindings you agree your project is GPLed too. Sorry about that!