The monadfibre package

[Tags: deprecated, gpl, library]

Deprecated

This package defines a Monad Transformer called Fibre, which provides the underlying monad with Choice and Parallelism. Also included is a Class called MonadBi which acts as a superset of MonadTrans, and provides raise analogous to lift as well as lower, which goes the other way. Natural instances are provided for many Monad Transformers.


[Skip to ReadMe]

Properties

Versions0.1, 0.1.1, 0.1.2, 0.1.2.1
Change logNone available
Dependenciesbase (>=3 && <5), mtl, stm [details]
LicenseGPL
AuthorAnupam Jain
Maintainerajnsit@gmail.com
StabilityExperimental
CategoryControl
UploadedWed Sep 21 02:15:14 UTC 2011 by AnupamJain
DistributionsNixOS:0.1.2.1
Downloads636 total (33 in last 30 days)
Votes
0 []
StatusDocs uploaded by user
Build status unknown [no reports yet]

Modules

[Index]

Downloads

Maintainers' corner

For package maintainers and hackage trustees

Readme for monadfibre-0.1

Monad Fibre (monadfibre-0.1)
============================

This package defines a Monad Transformer called Fibre, which provides the underlying monad with Choice and Parallelism.

Also included is a Class called @MonadBi@ which acts as a superset of MonadTrans, and provides raise analogous to lift as well as lower, which goes the other way.
Natural instances are provided for many Monad Transformers.