opaleye-trans: A monad transformer for Opaleye

[ bsd3, database, library, program ] [ Propose Tags ]

A monad transformer for Opaleye with exceptions

Versions 0.1.0, 0.1.1, 0.2.0, 0.3.0, 0.3.1, 0.3.2, 0.3.3, 0.3.4, 0.3.5, 0.3.6, 0.3.7, 0.4.0, 0.4.1, 0.4.2, 0.4.3, 0.5.0
Dependencies base (>=4.8 && <4.12), exceptions (>=0.6 && <0.11), mtl (==2.2.*), opaleye (>=0.4 && <0.7), opaleye-trans, postgresql-simple (>=0.4 && <0.6), product-profunctors (>=0.6 && <0.11), transformers (>=0.3 && <0.6) [details]
License BSD-3-Clause
Copyright (c) 2015 Bitnomial, Inc
Author Matthew Wraith
Maintainer wraithm@gmail.com
Category Database
Home page https://github.com/WraithM/opaleye-trans
Source repo head: git clone https://github.com/WraithM/opaleye-trans
Uploaded by LukeHoersten at Thu Aug 9 15:14:51 UTC 2018
Distributions NixOS:0.5.0
Executables opaleye-rosetree2, opaleye-rosetree
Downloads 2777 total (200 in the last 30 days)
Rating (no votes yet) [estimated by rule of succession]
Your Rating
  • λ
  • λ
  • λ
Status Docs available [build log]
Last success reported on 2018-08-09 [all 1 reports]
Hackage Matrix CI

Modules

[Index] [Quick Jump]

Downloads

Maintainer's Corner

For package maintainers and hackage trustees