The packdeps package

[Tags:bsd3, library, program]

This provides a library and command line tool for checking if the upper bounds in your package's dependency list excludes the newest package available. The code was originally available only as a web interface at, but is now available for standalone use as well.

The command line tool has an incredibly simple interface: simply pass it a list of cabal files, and it will tell you what dependencies- if any- are restricted.

[Skip to Readme]


Versions 0.0.0, 0.0.1,, 0.0.3,, 0.2.0, 0.3.0,,,,, 0.4.1, 0.4.2,, 0.4.3
Change log
Dependencies base (>=4.6 && <5), bytestring (>=0.9), Cabal (>=1.14 && <1.25), containers (>=0.2), directory (>=1.0), filepath (>=1.1), packdeps, split (>=, tar (>=0.4 && <0.6), text (>=0.7), time (>=1.1.4) [details]
License BSD3
Author Michael Snoyman <>
Maintainer Michael Snoyman <>
Stability Stable
Category Distribution
Home page
Source repository head: git clone git://
Uploaded Wed Oct 19 16:30:09 UTC 2016 by MichaelSnoyman
Distributions LTSHaskell:0.4.3, NixOS:0.4.3, Stackage:0.4.3, Tumbleweed:
Downloads 4844 total (50 in the last 30 days)
0 []
Status Docs available [build log]
Last success reported on 2016-10-19 [all 1 reports]




Maintainer's Corner

For package maintainers and hackage trustees

Readme for packdeps

Readme for packdeps-0.4.3


Build Status

Check the upper bounds on a package to determine if there are newer versions of dependencies.