The users-postgresql-simple package

[Tags:library, mit, test]

This library is a backend driver using postgresql-simple for the "users" library.

It supports all postgres versions starting from 8.3 and requires the included extensions uuid-ossp.

The package itself does not expose any bindings but provides an instance for UserStorageBackend.

Usage:

 module Foo where
 import Web.Users.Types
 import Web.Users.Postgresql ()
 -- code goes here

Properties

Versions 0.1.0.0, 0.1.0.1, 0.2.0.0, 0.3.0.0, 0.4.0.0, 0.5.0.0, 0.5.0.1, 0.5.0.2
Dependencies base (>=4.6 && <5), bytestring (>=0.10), mtl (>=2.1), postgresql-simple (>=0.4), text (>=1.2), time (>=1.4), users (>=0.5.0.0), uuid (>=1.3) [details]
License MIT
Copyright (c) 2015 - 2016 Alexander Thiemann
Author Alexander Thiemann <mail@athiemann.net>
Maintainer Alexander Thiemann <mail@athiemann.net>
Category Web
Home page https://github.com/agrafix/users
Bug tracker https://github.com/agrafix/users/issues
Source repository head: git clone git://github.com/agrafix/users.git
Uploaded Sun May 22 09:50:18 UTC 2016 by AlexanderThiemann
Distributions LTSHaskell:0.5.0.2, NixOS:0.5.0.2, Stackage:0.5.0.2, Tumbleweed:0.5.0.2
Downloads 859 total (17 in the last 30 days)
Votes
0 []
Status Docs available [build log]
Last success reported on 2016-11-25 [all 1 reports]
Hackage Matrix CI

Modules

[Index]

Downloads

Maintainer's Corner

For package maintainers and hackage trustees