The vty-ui package

[Tags: bsd3, deprecated, library]

Deprecated in favor of brick

An extensible library of user interface widgets for composing and laying out Vty user interfaces. This library provides a collection of primitives for building and composing widgets and creating Vty Images. This library is intended to make non-trivial user interfaces trivial to express and modify without having to worry about terminal size.


Versions0.1, 0.2, 0.3, 0.4, 1.0, 1.0.1, 1.1, 1.2, 1.3, 1.3.1, 1.4, 1.5, 1.5.1, 1.6, 1.6.1, 1.7, 1.7.1, 1.8, 1.9
Change logNone available
Dependenciesbase (==4.*), containers (==0.2.*), mtl (==1.1.*), pcre-light (==0.3.*), QuickCheck (==2.1.*), vty (==4.0.*) [details]
AuthorJonathan Daugherty <>
MaintainerJonathan Daugherty <>
CategoryUser Interfaces
Home page
Executablesvty-ui-demo, vty-ui-tests
UploadedFri Feb 19 06:21:02 UTC 2010 by JonathanDaugherty
Downloads3750 total (161 in last 30 days)
0 []
StatusDocs not available [build log]
All reported builds failed as of 2015-06-10 [all 1 reports]



testingBuild for testingDisabledAutomatic

Use -f <flag> to enable a flag, or -f -<flag> to disable that flag. More info


Maintainers' corner

For package maintainers and hackage trustees