beam-postgres: Connection layer between beam and postgres

[ database, library, mit ] [ Propose Tags ]

Beam driver for PostgreSQL, an advanced open-source RDBMS

Versions [faq] 0.3.0.0, 0.3.1.0, 0.3.2.0, 0.3.2.2, 0.3.2.3, 0.4.0.0, 0.5.0.0
Change log ChangeLog.md
Dependencies aeson (>=0.11 && <1.3), base (>=4.7 && <5.0), beam-core (>=0.7 && <0.7.2), beam-migrate (==0.3.*), bytestring (==0.10.*), case-insensitive (==1.2.*), conduit (>=1.2 && <1.4), free (>=4.12 && <5.1), hashable (>=1.1 && <1.3), haskell-src-exts (>=1.18 && <1.21), lifted-base (==0.2.*), monad-control (==1.0.*), mtl (>=2.1 && <2.3), network-uri (==2.6.*), postgresql-libpq (>=0.8 && <0.10), postgresql-simple (==0.5.*), scientific (==0.3.*), text (>=1.0 && <1.3), time (>=1.6 && <1.10), unordered-containers (==0.2.*), uuid (>=1.2 && <1.4), vector (>=0.11 && <0.13) [details]
License MIT
Author Travis Athougies
Maintainer travis@athougies.net
Revised Revision 1 made by HerbertValerioRiedel at 2019-03-16T22:38:58Z
Category Database
Home page http://tathougies.github.io/beam/user-guide/backends/beam-postgres
Bug tracker https://github.com/tathougies/beam/issues
Source repo head: git clone https://github.com/tathougies/beam.git(beam-postgres)
Uploaded by TravisAthougies at 2018-04-11T05:26:40Z
Distributions NixOS:0.5.0.0, Stackage:0.4.0.0
Downloads 4190 total (77 in the last 30 days)
Rating (no votes yet) [estimated by Bayesian average]
Your Rating
  • λ
  • λ
  • λ
Status Hackage Matrix CI
Docs not available [build log]
All reported builds failed as of 2018-04-13 [all 3 reports]

Modules

  • Database
    • Beam
      • Database.Beam.Postgres
        • Database.Beam.Postgres.Conduit
        • Database.Beam.Postgres.Full
        • Database.Beam.Postgres.Migrate
        • Database.Beam.Postgres.PgCrypto
        • Database.Beam.Postgres.Syntax

Flags

NameDescriptionDefaultType
werror

Enable -Werror during development

DisabledManual

Use -f <flag> to enable a flag, or -f -<flag> to disable that flag. More info

Downloads

Note: This package has metadata revisions in the cabal description newer than included in the tarball. To unpack the package including the revisions, use 'cabal get'.

Maintainer's Corner

For package maintainers and hackage trustees