jsc: High level interface for webkit-javascriptcore

[ deprecated, javascript, library, mit, web ] [ Propose Tags ]
Deprecated. in favor of jsaddle

This package provides an EDSL for calling JavaScript code using the JavaScriptCore engine and low level Haskell bindings in the webkit-javascriptcore library https://github.com/ghcjs/webkit-javascriptcore.

Flags

Automatic Flags
NameDescriptionDefault
gtk3

Use GTK3 rather than GTK2

Enabled
jsffi

Use JavaScriptFFI extension for GHCJS JavaScript output

Enabled
webkit

Use WebKitGtk and JavaScriptCore for GHCJS output

Disabled
jmacro

Include some JMacro support

Enabled

Use -f <flag> to enable a flag, or -f -<flag> to disable that flag. More info

Downloads

Maintainer's Corner

For package maintainers and hackage trustees

Candidates

  • No Candidates
Versions [RSS] 0.1.1.0, 0.1.1.1
Dependencies base (<5), jmacro (>=0.6.3 && <0.8), lens (>=3.8.5 && <4.1), template-haskell, text (>=0.11.2.3 && <1.2), transformers (>=0.3.0.0 && <0.4), webkit (>=0.12.5 && <0.13), webkit-javascriptcore (>=0.12.5 && <0.13), webkitgtk3 (>=0.12.5 && <0.13), webkitgtk3-javascriptcore (>=0.12.5 && <0.13) [details]
License MIT
Author Hamish Mackenzie
Maintainer Hamish Mackenzie <Hamish.K.Mackenzie@googlemail.com>
Category Web, Javascript
Source repo head: git clone https://github.com/ghcjs/jsc
Uploaded by HamishMackenzie at 2014-03-02T17:41:37Z
Distributions NixOS:0.1.1.1
Downloads 1730 total (10 in the last 30 days)
Rating (no votes yet) [estimated by Bayesian average]
Your Rating
  • λ
  • λ
  • λ
Status Docs uploaded by user [build log]
All reported builds failed [all 1 reports]