The metaplug package

[Tags:bsd3, deprecated, library]
Deprecated. in favor of hint

a ghc-api wrapper, designed to make the api more transparent across releases and offer eval and plugin esque facilities in the form of a simple, easy to modify library.

[Skip to Readme]


Versions 0.1, 0.1.1
Dependencies base, Cabal, filepath, ghc (>=6.6), haskell98 [details]
License BSD3
Author Austin Seipp
Stability experimental
Uploaded Thu Oct 11 02:32:02 UTC 2007 by AustinSeipp
Distributions NixOS:0.1.1
Downloads 451 total (8 in the last 30 days)
0 []
Status Docs uploaded by user
Build status unknown [no reports yet]




Maintainer's Corner

For package maintainers and hackage trustees

Readme for metaplug

Readme for metaplug-0.1.1

metaplug: a ghc api wrapper

* intro *
metaplug is a small, usable wrapper around the
glasgow haskell compiler's interal API. it provides
facilities for loading and calling into external
haskell modules, as well as in-situ evaluation
facilities (and other small things.)

* install *

  o ghc 6.6.x


$ chmod +x Setup.lhs
$ ./Setup.lhs configure
$ ./Setup.lhs build
$ ./Setup.lhs install

metaplug is now installed! :)

* patches *
patches may be sent via darcs send to
austin at youareinferior dot noet

- austin seipp, 2007