vect-floating-accelerate: Accelerate instances for vect-floating types

[ bsd3, deprecated, library, math ] [ Propose Tags ]
Deprecated. in favor of linear-accelerate

Provides accelerate compatibility of vect-floating http://hackage.haskell.org/package/vect-floating. Includes Vec2, Normal2, Vec3, Normal3, Vec4, Normal4, Quaternion and UnitQuaternion. Credit to Trevor L. McDonell http://github.com/tmcdonell for examples on how to make data types compatible with accelerate.

Versions 0.1.0.1, 0.1.0.2, 0.1.0.3, 0.1.0.4
Dependencies accelerate (>=0.14.0.0 && <=0.15.0.0), base (>=3 && <5), vect-floating (==0.1.0.4) [details]
License BSD-3-Clause
Copyright (c) 2014 Charles Durham
Author Charles Durham
Maintainer Charles Durham <cpdurham@gmail.com>
Revised Revision 1 made by cdurham at Thu Sep 25 09:03:25 UTC 2014
Category Math
Home page http://github.com/cpdurham/vect-floating-accelerate
Uploaded by cdurham at Thu Sep 25 08:59:37 UTC 2014
Distributions NixOS:0.1.0.4
Downloads 1459 total (7 in the last 30 days)
Rating (no votes yet) [estimated by rule of succession]
Your Rating
  • λ
  • λ
  • λ
Status Docs uploaded by user
Build status unknown [no reports yet]
Hackage Matrix CI

Modules

[Index]

Downloads

Note: This package has metadata revisions in the cabal description newer than included in the tarball. To unpack the package including the revisions, use 'cabal get'.

Maintainer's Corner

For package maintainers and hackage trustees