yi-vty: Vty backend for Yi

[ deprecated, editor, library ] [ Propose Tags ]
Deprecated. in favor of yi

Core functions for the Vty backend of Yi. Note that you will need the yi package to use this.

Note that this package is intended for Yi versions 0.2 and below, *not* 0.3, 0.4 or up. This and yi-gtk are functionally obsolete.

Modules

  • Yi
    • Yi.Buffer
    • Yi.Char
    • Yi.CharMove
    • Yi.Core
    • Yi.CoreUI
    • Yi.Debug
    • Yi.Editor
    • Yi.Eval
    • Yi.Event
    • Yi.FastBuffer
    • Yi.History
    • Yi.Interact
    • Yi.Kernel
    • Yi.Keymap
      • Yi.Keymap.Completion
      • Yi.Keymap.Ee
      • Yi.Keymap.Emacs
        • Yi.Keymap.Emacs.Keys
        • Yi.Keymap.Emacs.KillRing
        • Yi.Keymap.Emacs.UnivArgument
      • Yi.Keymap.Joe
      • Yi.Keymap.Mg
      • Yi.Keymap.Nano
      • Yi.Keymap.Vi
      • Yi.Keymap.Vim
    • Yi.MkTemp
    • Yi.Process
    • Yi.Region
    • Yi.Search
    • Yi.String
    • Yi.Style
    • Yi.Syntax
      • Yi.Syntax.Table
    • Yi.UI
    • Yi.Undo
    • Yi.Version
    • Yi.Vty
    • Yi.Window
    • Yi.Yi

Downloads

Maintainer's Corner

For package maintainers and hackage trustees

Candidates

  • No Candidates
Versions [RSS] 0.2, 0.2.1, 0.3
Dependencies base, filepath (>=1.0), ghc (>=6.6), mtl, regex-posix, vty (>=3.0), yi (<=0.2) [details]
License LicenseRef-GPL
Author Don Stewart
Maintainer dons@cse.unsw.edu.au
Category Editor
Uploaded by GwernBranwen at 2008-08-18T21:19:11Z
Distributions NixOS:0.3
Downloads 2425 total (9 in the last 30 days)
Rating (no votes yet) [estimated by Bayesian average]
Your Rating
  • λ
  • λ
  • λ
Status Docs not available [build log]
All reported builds failed as of 2017-01-03 [all 8 reports]