Build #8 for yi-vty-0.2.1

[all reports]

Package yi-vty-0.2.1
Install DependencyFailed yi-0.2
Docs NotTried
Tests NotTried
Time submitted 2017-01-03 09:14:49.333008 UTC
Compiler ghc-8.0.1.20161018
OS linux
Arch x86_64
Dependencies base-4.9.0.0, filepath-1.4.1.0, ghc-8.0.1.20161018, mtl-2.2.1, regex-posix-0.95.2, vty-5.14, yi-0.2
Flags none

Code Coverage

No Code Coverage was submitted for this report.

Build log

[view raw]

Resolving dependencies...
Configuring data-default-class-0.1.2.0...
Configuring dlist-0.8.0.2...
Building data-default-class-0.1.2.0...
Building dlist-0.8.0.2...
Installed data-default-class-0.1.2.0
Configuring microlens-0.4.7.0...
Building microlens-0.4.7.0...
Installed dlist-0.8.0.2
Configuring mtl-2.2.1...
Building mtl-2.2.1...
Configuring old-locale-1.0.0.7...
Installed microlens-0.4.7.0
Building old-locale-1.0.0.7...
Configuring primitive-0.6.1.0...
Installed old-locale-1.0.0.7
Configuring parallel-3.2.1.0...
Installed mtl-2.2.1
Building primitive-0.6.1.0...
Building parallel-3.2.1.0...
Configuring stm-2.4.4.1...
Installed parallel-3.2.1.0
Building stm-2.4.4.1...
Configuring text-1.2.2.1...
Installed primitive-0.6.1.0
Building text-1.2.2.1...
Configuring transformers-compat-0.5.1.4...
Installed stm-2.4.4.1
Building transformers-compat-0.5.1.4...
Configuring utf8-string-1.0.1.1...
Installed transformers-compat-0.5.1.4
Building utf8-string-1.0.1.1...
Configuring data-default-instances-containers-0.0.1...
Installed utf8-string-1.0.1.1
Building data-default-instances-containers-0.0.1...
Installed data-default-instances-containers-0.0.1
Configuring data-default-instances-dlist-0.0.1...
Building data-default-instances-dlist-0.0.1...
Configuring data-default-instances-old-locale-0.0.1...
Installed data-default-instances-dlist-0.0.1
Building data-default-instances-old-locale-0.0.1...
Configuring microlens-th-0.4.1.0...
Installed data-default-instances-old-locale-0.0.1
Building microlens-th-0.4.1.0...
Configuring regex-base-0.93.2...
Installed text-1.2.2.1
Building regex-base-0.93.2...
Configuring microlens-mtl-0.1.10.0...
Installed regex-base-0.93.2
Building microlens-mtl-0.1.10.0...
Configuring vector-0.11.0.0...
Installed microlens-th-0.4.1.0
Building vector-0.11.0.0...
Installed microlens-mtl-0.1.10.0
Configuring data-default-0.7.1.1...
Building data-default-0.7.1.1...
Configuring blaze-builder-0.4.0.2...
Installed data-default-0.7.1.1
Building blaze-builder-0.4.0.2...
Configuring parsec-3.1.11...
Installed blaze-builder-0.4.0.2
Building parsec-3.1.11...
Configuring hashable-1.2.5.0...
Installed parsec-3.1.11
Building hashable-1.2.5.0...
Configuring regex-posix-0.95.2...
Installed hashable-1.2.5.0
Building regex-posix-0.95.2...
Installed regex-posix-0.95.2
Configuring yi-0.2...
Failed to install yi-0.2
Build log ( /home/builder/.cabal/logs/yi-0.2.log ):
cabal: Entering directory '/tmp/cabal-tmp-1538/yi-0.2'
cabal: Leaving directory '/tmp/cabal-tmp-1538/yi-0.2'
Installed vector-0.11.0.0
Configuring vty-5.14...
Building vty-5.14...
Installed vty-5.14
cabal: Error: some packages failed to install:
yi-0.2 failed during the configure step. The exception was:
user error ('/opt/ghc/8.0.2/bin/ghc' exited with an error:

/tmp/cabal-tmp-1538/yi-0.2/dist/setup/setup.hs:5:1: error:
Failed to load interface for ‘Distribution.Setup’
Perhaps you meant
Distribution.GetOpt
Distribution.Lex
Distribution.ReadE (from Cabal-1.24.0.0)
Use -v to see a list of the files searched for.
)
yi-vty-0.2.1 depends on yi-0.2 which failed to install.