The alsa-midi package

[Tags: deprecated, gpl, library, program]

Deprecated in favor of alsa-pcm

Bindings for the ALSA sequencer API (MIDI stuff) Since there is also http://code.haskell.org/alsa/ which aims at a more complete interface to ALSA we will no longer maintain this one.

See Sound.ALSA.Sequencer.Play for how to play Haskore songs in realtime via ALSA.


Properties

Versions0.3, 0.3.1, 0.3.2, 0.4, 0.4.0.1
Dependenciesbase (>=1.0 && <2), event-list (>=0.0.6 && <0.1), midi (==0.1.*), mtl (==1.*), non-negative (>=0.0.1 && <0.1), QuickCheck (==1.*) or
array, base (>=2), event-list (>=0.0.6 && <0.1), midi (==0.1.*), mtl (==1.*), non-negative (>=0.0.1 && <0.1), QuickCheck (==1.*)
LicenseGPL
AuthorSoenke Hahn
MaintainerHenning Thielemann <haskell@henning-thielemann.de>
CategorySound
Home pagehttp://www.haskell.org/haskellwiki/ALSA
Executablesmididump, playmidi, playnote
Upload dateThu Sep 25 17:52:31 UTC 2008
Uploaded byHenningThielemann
Downloads347 total (27 in last 30 days)

Modules

[Index]

Flags

NameDescriptionDefault
splitbaseChoose the new smaller, split-up base package.Enabled

Use -f <flag> to enable a flag, or -f -<flag> to disable that flag. More info

Downloads

Maintainers' corner

For package maintainers and hackage trustees