The bindings-mpdecimal package

[Tags: bsd3, deprecated, library]

Deprecated in favor of deka

mpdecimal provides correctly rounded arbitrary precision decimal floating point arithmetic.

Please see

[Skip to ReadMe]


Change logNone available
Dependenciesbase (==4.6.*), bindings-DSL (==1.0.*) [details]
AuthorOmari Norman
Home page
Source repositoryhead: git clone
UploadedMon Jan 20 14:41:49 UTC 2014 by OmariNorman
Downloads687 total (30 in last 30 days)
0 []
StatusDocs not available [build log]
All reported builds failed as of 2015-09-28 [all 4 reports]



Maintainers' corner

For package maintainers and hackage trustees

Readme for bindings-mpdecimal-

WARNING - this is a work in progress.  Do not use it yet.  I am checking the
types, which will take time.

Bindings to the mpdecimal library by Stefan Krah, which is available at

mpdecimal provides decimal floating point arithmetic.  It currently is
the basis for the decimal library in the Python standard library.
More information on decimal arithmetic is at

These bindings were written for mpdecimal version 2.4.0.  You will
need to install mpdecimal before you install this library.

These bindings were made using bindings-dsl:

and c2hsc: