casadi-bindings-internal: low level bindings to CasADi

[ lgpl, library, math, numerical ] [ Propose Tags ]

Debian/Ubuntu instructions

Version numbers correspond to the C++ library version numbers except the very last number which may indicate breaking changes.

This only works on Debian/Ubuntu at the moment (sorry).

Install libcasadi from a .deb package here: https://github.com/casadi/casadi/releases, I use libcasadi-shared. (Get the version corresponding to the current casadi-bindings version, for example casadi-bindings-1.9.0.0 is libcasadi 1.9.0)

Then, - `cabal update; cabal install casadi-bindings`

Temporary note: there is something wrong with casadi and ipopt related to http://list.coin-or.org/pipermail/ipopt/2014-April/003670.html, and https://github.com/casadi/casadi/issues/1075. At the moment this .cabal package works for me as is, but YMMV

Versions [faq] 0.1, 0.1.1, 0.1.2, 0.1.2.1, 0.1.3.0, 0.1.3.1, 0.1.4.0, 0.1.5.0, 0.1.6.0, 0.1.6.1
Dependencies base (>=4.6 && <5), vector (>=0.10) [details]
License LGPL-3.0-only
Copyright (c) 2013-2014 Greg Horn
Author Greg Horn
Maintainer gregmainland@gmail.com
Category Numerical, Math
Home page http://github.com/ghorn/casadi-bindings
Source repo head: git clone git://github.com/ghorn/casadi-bindings.git
Uploaded by GregHorn at Fri May 2 10:45:14 UTC 2014
Distributions NixOS:0.1.6.1
Downloads 3860 total (82 in the last 30 days)
Rating (no votes yet) [estimated by rule of succession]
Your Rating
  • λ
  • λ
  • λ
Status Hackage Matrix CI
Docs not available [build log]
All reported builds failed as of 2016-12-15 [all 8 reports]

Modules

  • Casadi
    • Internal
      • Casadi.Internal.CToolsImports
      • Casadi.Internal.CToolsInstances
      • Casadi.Internal.Callback
      • Casadi.Internal.CppHelpers
      • Casadi.Internal.FormatException
      • Casadi.Internal.Marshal
      • Casadi.Internal.MarshalTypes
      • Casadi.Internal.WrapReturn

Downloads

Maintainer's Corner

For package maintainers and hackage trustees